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Abstract
The GNOME User Guide is a collection of documentation which details general use of the GNOME Desktop
environment. Topics covered include sessions, panels, menus, file management, and preferences.
Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License (GFDL),
Version 1.1 or any later version published by the Free Software Foundation with no Invariant Sections, no Front-Cover Texts, and no
Back-Cover Texts. You can find a copy of the GFDL at this link or in the file COPYING-DOCS distributed with this manual.
This manual is part of a collection of GNOME manuals distributed under the GFDL. If you want to distribute this manual separately
from the collection, you can do so by adding a copy of the license to the manual, as described in section 6 of the license.
Many of the names used by companies to distinguish their products and services are claimed as trademarks. Where those names appear
in any GNOME documentation, and the members of the GNOME Documentation Project are made aware of those trademarks, then the
names are in capital letters or initial capital letters.
DOCUMENT AND MODIFIED VERSIONS OF THE DOCUMENT ARE PROVIDED UNDER THE TERMS OF THE GNU FREE
DOCUMENTATION LICENSE WITH THE FURTHER UNDERSTANDING THAT:
1.

DOCUMENT IS PROVIDED ON AN "AS IS" BASIS, WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, WARRANTIES THAT THE DOCUMENT OR MODIFIED VERSION OF
THE DOCUMENT IS FREE OF DEFECTS MERCHANTABLE, FIT FOR A PARTICULAR PURPOSE OR NON-INFRINGING.
THE ENTIRE RISK AS TO THE QUALITY, ACCURACY, AND PERFORMANCE OF THE DOCUMENT OR MODIFIED
VERSION OF THE DOCUMENT IS WITH YOU. SHOULD ANY DOCUMENT OR MODIFIED VERSION PROVE DEFECTIVE IN ANY RESPECT, YOU (NOT THE INITIAL WRITER, AUTHOR OR ANY CONTRIBUTOR) ASSUME THE COST OF
ANY NECESSARY SERVICING, REPAIR OR CORRECTION. THIS DISCLAIMER OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. NO USE OF ANY DOCUMENT OR MODIFIED VERSION OF THE DOCUMENT IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS DISCLAIMER; AND

2.

UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER IN TORT (INCLUDING NEGLIGENCE),
CONTRACT, OR OTHERWISE, SHALL THE AUTHOR, INITIAL WRITER, ANY CONTRIBUTOR, OR ANY DISTRIBUTOR
OF THE DOCUMENT OR MODIFIED VERSION OF THE DOCUMENT, OR ANY SUPPLIER OF ANY OF SUCH PARTIES,
BE LIABLE TO ANY PERSON FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES
OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER DAMAGES OR LOSSES ARISING OUT OF
OR RELATING TO USE OF THE DOCUMENT AND MODIFIED VERSIONS OF THE DOCUMENT, EVEN IF SUCH PARTY
SHALL HAVE BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES.

Feedback
To report a bug or make a suggestion regarding the GNOME desktop or this manual, follow the directions in the GNOME Feedback
Page.
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Chapter 1. Basic Skills

Mouse Skills

This chapter introduces you to the basic skills that you need to work with the GNOME Desktop.

Mouse Skills
This section describes the button conventions and action terminology used in this manual, and also the mouse pointers used throughout the desktop and applications.

Mouse Button Conventions
All the instructions in this manual are for the following types of mouse devices:
•

Devices that are configured for right-hand users.

•

Three button devices.

The mouse button conventions used in this manual are as follows:
Left mouse button
The button on the left side of a mouse device configured for normal right-hand use.
Middle mouse button
The middle button of a mouse device configured for normal right-hand use. On many mice with a scroll wheel,
the scroll wheel can be pushed directly down for a middle mouse button click.
Right mouse button
The button on the right side of a mouse device configured for normal right-hand use.
To reverse the handedness of your mouse device, start the Mouse Preferences, then select the options that you require. If you do reverse the handedness of your mouse device, then you must reverse the mouse button conventions
used in this manual. See the section called “Mouse Preferences” for more information about setting your mouse
preferences.
If you have a two-button mouse device, then your system may be configured to allow you to press the left and right
mouse buttons simultaneously to simulate the effect of a middle mouse button press.

Mouse Actions
The following conventions are used in this manual to describe actions that you take with the mouse:
Action

Definition

Click

Press and release the left mouse button, without moving the mouse.

Left-click

Same as click. The term 'left-click' is used where there might be confusion with right-click.

Middle-click

Press and release the middle mouse button, without moving the mouse.

Right-click

Press and release the right mouse button, without moving the mouse.

Double-click

Press and release the left mouse button twice in rapid succession without
moving the mouse. You can configure the sensitivity to double-clicks by
changing the Double-click Timeout setting: see the section called “Mouse
Preferences” for more information.
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Action

Definition

Drag

Press and do not release the left mouse button, and then move the mouse
with the button still held down, and finally release the button.
Dragging with the mouse is used in many different contexts. This moves
an object around the screen with the mouse. The object is dropped at the
location where the mouse button is released. This action is also called
drag-and-drop. Clicking on an element of the interface to move it is
sometimes called a grab. Click and drag
For example, you can change the position of a window by dragging on its
title bar, or move a file by dragging its icon from one window and dropping it on another.
The left mouse buttons is usually used to perform drag actions, although
the middle mouse button is sometimes used for an alternate drag action.

Click-and-hold

Press and do not release the left mouse button.

You can perform the following actions with the mouse:
Left mouse button
•

Select text.

•

Select items.

•

Drag items.

•

Activate items.

Middle mouse button
•

Paste text.

•

Move items.

•

Move windows to the back.

Right mouse button
Use the right mouse button to open a context menu for an item, if a menu applies. For most items, you can also
use the Shift-F10 keyboard shortcut to open the context menu once the item has been selected.
For example, when viewing files in the file manager, you select a file by clicking with the left mouse button and
open a file by double-clicking with the left mouse button. Clicking with the right mouse button will bring up a context menu for that file.
In most applications, you can select text with your left mouse button and paste it in another application
using the middle mouse button. This is called primary selection paste, and works separately from your
normal clipboard operations.

To select more than one item, you can hold the Ctrl key to select multiple items, or hold the Shift key
to select a contiguous range of items. You can also drag a bounding box to select several items by starting the drag in the empty space around items and dragging out a rectangle.
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Mouse Pointers
As you use the mouse, the appearance of the mouse pointer can change. The appearance of the pointer provides
feedback about a particular operation, location, or state.
The following mouse pointers are shown as your mouse passes over different elements of the screen:
Your mouse pointers will differ from those shown here if you are using a different pointer theme. Your
distributor or vendor may have set a different default theme.
Normal pointer
This pointer appears during normal use of the mouse.
Busy pointer
This pointer appears over a window that is busy performing a task. You cannot use the mouse to give this window any input, but you can move to another window and work with that.
Resize pointer
This pointer indicates that you can grab the control to resize parts of the interface. This appears over the borders
of windows and over resize handles between panes in a window. The direction of the arrows indicates in which
direction you can resize.
Hand pointer
This pointer appears when you hover over a hypertext link, in a web page for example. This pointer indicates
that you can click on the link to load a new document or perform an action.
I-beam pointer
This pointer is shown when the mouse is over text that you can select or edit. Click to place the cursor where
you want to type text, or drag to select text.
The following mouse pointers are shown when dragging an item such as a file, or a piece of text. They indicate the
result of releasing the mouse button to drop the object being moved.
Move pointer
This pointer indicates that when you drop the object, the object is moved from the old location to the new location.
Copy pointer
This pointer indicates that when you drop the object, a copy of the object is created where you drop it.
Symbolic link pointer
This pointer indicates that when you drop the object, a symbolic link to the object is created where you drop the
object. A symbolic link is a special type of file that points to another file or folder. For more on this, see the section called “Creating a Symbolic Link to a File or Folder”.
Ask pointer
This pointer indicates that when you drop the object, you will be given a choice of what to do. A menu will
open to allow you to choose which operation you would like to perform. For instance, you may be able to move,
copy, or create a symbolic link.
Not available pointer
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This pointer indicates that you cannot drop the object at the current location. Releasing the mouse button now
will have no effect: the dragged object will be returned to its starting location.
Move panel object pointer
This pointer appears when you drag a panel or a panel object with the middle mouse button. See Chapter 4,
Working With Panels for more information on panels.
Move window pointer
This pointer appears when you drag a window to move it. See the section called “Manipulating Windows” for
more information on moving windows.

Keyboard Skills
For almost every task that you can perform with the mouse, you can use the keyboard to perform the same task.
Shortcut keys are keys that provide you with a quick way to perform a task.
You can use shortcut keys to perform general GNOME Desktop tasks and to work with interface items such as panels and windows. You can also use shortcut keys in applications. To customize your shortcut keys, use the Keyboard
Shortcuts preference tool. See the section called “Keyboard Shortcuts Preferences” for more information about configuring keyboard shortcuts.
Many PC keyboards come with two special keys for the Windows operating system: a key with a Microsoft Windows™ logo and a key for accessing context menus.
In GNOME, the Windows key is often configured to act as an additional modifier key, called the Super
key. The context menu key can be used to access the context menu of the selected item, just as the
Shift-F10 keyboard shortcut can.
You can also modify the GNOME Desktop preferences to use keyboard accessibility features. See the section called
“Keyboard Accessibility Preferences” for more information about the keyboard accessibility features.
The following sections describe the shortcut keys that you can use throughout the desktop and applications.

Global Shortcut Keys
Global shortcut keys enable you to use the keyboard to perform tasks related to your desktop, rather than tasks on
the currently selected window or application. The following table lists some global shortcut keys:
Shortcut Key

Function

Alt-F1

Open the Applications Menu.

Alt-F2

Display the Run Application dialog. See the section called “Running Applications” for more information.

Print Screen

Take a screenshot of the entire desktop. See the section called “Taking
Screenshots” for more information.

Alt-Print Screen

Take a screenshot of the currently focused window.

Ctrl-Alt-Arrow keys

Switch to the workspace to the specified direction of the current workspace. See the section called “Workspaces” for more information on
working with multiple workspaces.
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Shortcut Key

Function

Ctrl-Alt-D

Minimize all windows and give focus to the desktop.

Alt-Tab

Switch between windows. A list of windows that you can select is displayed. Release the keys to select a window. You can press the Shift key
to cycle through the windows in reverse order.

Ctrl-Alt-Tab

Switch the focus between the panels and the desktop. A list of items that
you can select is displayed. Release the keys to select an item. You can
press the Shift key to cycle through the items in reverse order.

Window Shortcut Keys
Window shortcut keys allow you to use the keyboard to perform tasks on the currently focused window. The following table lists some window shortcut keys:
Shortcut Key

Function

Alt-Tab

Switch between windows. A list of windows that you can select is displayed. Release the keys to select a window. You can press the Shift key
to cycle through the windows in reverse order.

Alt-F4

Close the currently focused window.

Alt-F5

Unmaximize the current window, if it is maximized.

Alt-F7

Move the currently focused window. After pressing this shortcut, you can
move the window using either the mouse or the arrow keys. To finish the
move, click the mouse or press any key on the keyboard.

Alt-F8

Resize the currently focused window. After pressing this shortcut, you can
resize the window using either the mouse or the arrow keys. To finish the
resize, click the mouse or press any key on the keyboard.

Alt-F9

Minimize the current window.

Alt-F10

Maximize the current window.

Alt-spacebar

Open the window menu for the currently selected window. The window
menu allows you to perform actions on the window, such as minimizing,
moving between workspaces, and closing.

Shift-Ctrl-Alt-Arrow keys

Move the current window to another workspace in the specified direction.
See the section called “Workspaces” for more information on working
with multiple workspaces.
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Application Keys
Application shortcut keys enable you to perform application tasks. You can use shortcut keys to perform application
tasks more quickly than if you use a mouse. The following table lists some common application shortcut keys:
Shortcut Key

Command

Ctrl-N

Create a new document or window.

Ctrl-X

Cut the selected text or region and place it on the clipboard.

Ctrl-C

Copy the selected text or region onto the clipboard.

Ctrl-V

Paste the contents of the clipboard.

Ctrl-Z

Undo the last action.

Ctrl-S

Save the current document to disk.

F1

Load the online help document for the application.

In addition to these shortcut keys, all applications support a set of keys to navigate and work with the user interface.
These keys allow you to perform operations that you might normally perform with a mouse. The following table describes some interface control keys:
Keys

Command

Arrow keys or Tab

Move between controls in the interface or items in a list.

Enter or spacebar

Activate or choose the selected item.

F10

Activate the left-most menu of the application window.

Shift-F10

Activate the context menu for the selected item.

Esc

Close a menu without selecting a menu item, or cancel a drag
operation.

Access Keys
A menubar is a bar at the top of a window that contains the menus for the application. An access key is an underlined letter in a menubar, menu, or dialog that you can use to perform an action. On a menubar, the access key for
each menu is underlined.
To open a menu, hold the Alt key, then press the access key. In the menu, the access key for each menu item is underlined. To choose a menu item when a menu is displayed, you can simply press the access key for the menu item.
For example, to open a new window in the Help application, press Alt-F to open the File menu, then press N to activate the New Window menu item.
You can also use access keys to access elements in a dialog. In a dialog, one letter in most dialog elements is underlined. To access a particular dialog element, hold Alt, then press the access key.
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Introduction

This chapter introduces you to some of the very basic components of the desktop. These components include Windows, Workspaces, and Applications. Almost all the work (or play) that you do in GNOME will involve these very
basic components.
This chapter describes the default configuration of GNOME. Your vendor or system administrator may
have configured your desktop to look different than what is described here.

Introduction
When you start a desktop session for the first time, you should see a default startup screen, with panels, windows,
and various icons.
The major components of the GNOME Desktop are as follows:
Desktop
The desktop itself is behind all of the other components on the desktop. You can place objects on the desktop to
access your files and directories quickly, or to start applications that you use often. See the section called “The
Desktop” for more information.
Panels
The panels are the two bars that run along the top and bottom of the screen. By default, the top panel shows you
the GNOME main menu bar, the date and time, and the launcher for the GNOME help system, and the bottom
panel shows you the list of open windows and the workspace switcher.
Panels can be customized to contain a variety of tools, such as other menus and launchers, and small utility applications, called panel applets. For example, you can configure your panel to display the current weather for
your location. For more information on panels, see Chapter 4, Working With Panels.
Windows
Most applications run inside of one or more windows. You can display multiple windows on your desktop at the
same time. Windows can be resized and moved around to accommodate your workflow. Each window has a titlebar at the top with buttons which allow you to minimize, maximize, and close the window. For more information on working with windows, see the section called “Windows”.
Workspaces
You can subdivide your desktop into separate workspaces. Each workspace can contain separate windows, allowing you to group related tasks together. For more information on working with workspaces, see the section
called “Workspaces”.
File Manager
The Nautilus file manager provides access to your files, folders, and applications. You can manage the contents
of folders in the file manager and open the files in the appropriate applications. See Chapter 6, Nautilus File
Manager for more information.
Preferences
You can customize your desktop using the desktop preference tools. Each tool controls a particular part of the
behavior of the desktop. The preference tools can be found in the Preferences submenu of the Desktop top-level
menu on your panel. See Chapter 8, Configuring Your Desktop for more information on the various preference
tools.
Your vendor or system administrator can make configuration changes to suit your needs, so your desktop might not
match exactly what is described in this manual. Nevertheless, this manual provides a useful introduction to using the
various components of your desktop.
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The Desktop
The desktop lies behind all other components on your screen. When no windows are visible, the desktop is that part
of the screen between the top and bottom panels. You can place files and folders on the desktop that you want to
have easy access to.
The desktop also has several special objects on it:
•

The Computer icon gives you access to CDs, removable media such as floppy disks, and also the entire filesystem (also known as the root filesystem). By default, you do not have the security permissions to read other users'
files or edit system files, but you may need to do so something such as configure a web server on the computer.

•

Your Home Folder, labelled username's Home, where all of your personal files are kept. You can also open
this folder from the Places menu.

•

The Trash is a special folder in which to place files and folders you no longer need. For more on this, see the
section called “Using Trash”.

•

When you insert a CD, a flashdrive, or other removable media, or a device containing files such as a music player or a digital camera, an icon representing this device will appear on the desktop.

As you work with your computer, the desktop becomes obscured by the windows you are working with. To quickly
reveal the desktop by minimizing all windows, you can do one of the following:
•

Click on the Show Desktop button at the far left of the bottom panel.

•

Press Ctrl-Alt-D.

Either action will also restore your windows to their previous state. Alternatively, you can switch to another workspace to see the desktop.
You can change the colour of the desktop background or the image displayed there. For more on this, see the section
called “Desktop Background Preferences”.
The files and folders you put on the desktop are stored in a special folder within your Home Folder,
called Desktop. Like any other folder, you can put files (and other folders) directly into it, they will
just also happen to show up on desktop itself.

Windows
A window is a rectangular area of the screen, usually with a border all around and a title bar at the top. You can
think of a window as a screen within the screen. Each window displays an application, allowing you to to have more
than one application visible, and work on more than one task at a time. You can also think of windows as pieces of
paper on your desktop: they can overlap, or be side by side, for example.
You can control a window's position of the screen, as well as its size. You can control which windows overlap other
windows, so the one you want to work with is completely visible. For more about moving and resizing windows, see
the section called “Manipulating Windows”.
Each window is not necessarily a different application. An application usually has one main window, and may open
additional windows at the request of the user.
The rest of this section describe the different types of windows and how you can interact with them.
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Types of Windows
There are two main types of window:
Application windows
Application windows allow all the minimize, maximize and close operations through the buttons on the titlebar.
When opening an application you will usually see a window of this type appear.
Dialog windows
Dialog windows appear at the request of an application window. A dialog window may alert you to a problem,
ask for confirmation of an action, or request input from you.
For example, if you tell an application to save a document, a dialog will ask you where you want to save the
new file. If you tell an application to quit while it is still busy, it may ask you to confirm that you want it to
abandon work in progress.
Some dialogs do not allow you to interact with the main application window until you have closed them: these
are called modal dialogs. Others can be left open while you work with the main application window: these are
called transient dialogs.
You can select the text in a dialog with the mouse. This allows you to copy it to the clipboard
(CTRL-C to copy), and paste it into another application. You may wish to quote the text you see
in a dialog when requesting support on the Internet.

Manipulating Windows
You can change the size and position of windows on the screen. This allows you to see more than one application
and do different tasks at the same time. For example, you might want to read text on a web page and write with a
word processor; or simple change to another application to do a different task or see the progress.
You can minimize a window if you are not currently interested in seeing it. This hides it from view. You can maximise a window to fill the whole screen so you can give it your full attention.
Most of these actions are carried out by using the mouse on different parts of the the window's frame (see the section
called “Actions” for a recap of using the mouse). The top edge of the window frame, called the titlebar because it
also displays the title of the window, contains several buttons that change the way the window is displayed. Figure 2.1, “Titlebar for a Typical Application Window” shows the titlebar for a typical application window.

Figure 2.1. Titlebar for a Typical Application Window

All actions can also be carried out from the Window Menu. To open this, click on the Window Menu Button at the
left-hand edge of the titlebar. Common actions can also be carried out with keyboard shortcuts: see the section called
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“Window Shortcut Keys” for a simple list of these. The following lists the actions you can carry out on a window,
with the mouse or the keyboard:
Move the window
Drag the titlebar to move the window. You can click on any part of the titlebar except the buttons at either end
to begin the drag action. The window will move on the screen as you drag the mouse. On less powerful computers, the movement of the window may be represented by moving an outline of its frame.
You can also choose Move from the Window Menu, or press Alt-F7, and then either move the mouse or press
the keyboard arrow keys to move the window.
You can also press-and-hold Alt and drag any part of the window.
As you move the window, some parts of the screen will give slight resistance to movement. This is to help you
align windows more easily to the edges of the desktop, the panels, and the edges of other windows.
You can also press-and-hold Shift while you move the window to cause it to only move between the corners of
the desktop and other windows.
If the Num Lock key is off, you can use the arrows on the numeric keypad, as well as the 7, 9, 1,
and 3 keys to move diagonally.
Resize the window
Drag one of the borders to expand or contract the window on that side. Drag a corner to change two sides at
once. The resize pointer appears when your mouse is in the correct position to begin the drag action.
You can also choose Resize from the Window Menu, or press Alt-F8. The resize pointer appears. Move the
mouse in the direction of the edge you want to resize, or press one of the keyboard arrows keys. The pointer
changes to indicate the chosen edge. Now you can use the mouse or the arrow keys to move this edge of the
window. Click the mouse or press Return to accept the change. Press Escape to cancel the resize action and return the window to its original size and shape.
Minimize the window
Click on the Minimize button in the titlebar, the leftmost of the group of three on the right. This removes the
window from view. The window can be restored to its previous position and size on the screen from the window
list on the bottom edge panel or the window selector in the top panel.
You can also choose Minimize from the Window Menu, or press Alt-F9.
A minimized window is shown in the window list and the window selector with [ ] around its title.
Maximize the window
Click on the Maximize button in the titlebar, the middle of the group of three on the right. This expands the
window so it fills the screen (the panels remain visible).
You can also choose Maximize from the Window Menu, or press Alt-F10, or double-click any part of the titlebar except the buttons at either end.
If you prefer, you can assign the double-click action to roll up the window: see the section called
“Windows Preferences”.
Unmaximize the window
When a window is maximized, click again on the Maximize button to restore it to its previous position and size
on the screen.
You can also choose Unmaximize from the Window Menu, press Alt-F5, or double-click any part of the titlebar
12
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except the buttons at either end.
Close the window
Click the Close button, the rightmost of the group of three on the right. This could close the application too. The
application will ask you to confirm closing a window that contains unsaved work.
Workspaces commands or a link to them still to go in this section, perhaps

Giving Focus to a Window
To work with an application, you need to give the focus to its window. When a window has focus, any actions such
as mouse clicks, typing text, or keyboard shortcuts, are directed to the application in that window. Only one window
can have focus at a time. The window that has focus will appear on top of other windows, so nothing covers any part
of it. It may also have a different appearance from other windows, depending on your choice of theme.
You can give the focus to a window in any of the following ways:
•

With the mouse, click on any part of the window, if the window is visible.

•

On the bottom panel, click on the window list button that represents the window in the Window List.

•

On the Menu Panel, click the window list icon and choose the window you want to switch to from the list. The
window list icon is at the extreme right of the panel, and its icon matches that of the current window's Window
Menu button.
If the window you choose is on a different workspace, you will be switched to that workspace. For
more on workspaces, see the section called “Workspaces”.

•

With the keyboard, hold the [Alt] key and press the [Tab] key. A pop-up window appears with a list of icons representing each window. While still holding [Alt], press [Tab] to move the selection along the list: a black rectangle frames the selected icon and the position of the window it corresponds to is highlighted with a black border. When the window you want to see is selected, release the [Alt] key. Using [Shift+Tab] instead of just [Tab]
cycles through the icons in reverse order.
You can customize the shortcut used to perform this action with the Keyboard Shortcuts preference
tool.

Workspaces
Workspaces allow you to manage which windows are on your screen. You can imagine workspaces as being virtual
screens, which you can switch between at any time. Every workspace contains the same desktop, the same panels,
and the same menus. However, you can run different applications, and open different windows in each workspace.
The applications in each workspace will remain there when you switch to other workspaces.
By default, four workspaces are available. You can switch between them with the Workspace Switcher applet at the
right of the bottom panel. This shows a representation of your workspaces, by default a row of four rectangles. Click
on one to switch to that workspace. In Figure 2.2, “Workspaces Displayed in Workspace Switcher”, Workspace
Switcher contains four workspaces. The first three workspaces contain open windows. The last workspace does not
contain currently open windows. The currently active workspace is highlighted.

Figure 2.2. Workspaces Displayed in Workspace Switcher
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Each workspace can have any number of applications open in it. The number of workspaces can be customized: see
the section called “Adding Workspaces”.
Workspaces enable you to organize the GNOME Desktop when you run many applications at the same
time. One way to use workspaces is to allocate a specific function to each workspace: one for email,
one for web browsing, one for graphic design, etc. However, everyone has their own preference and
you are in no way restricted to only using workspaces like this.

Switching Between Workspaces
You can switch between workspaces in any of the following ways:
•

In the Workspace Switcher applet in the bottom panel, click on the workspace where you want to work.

•

Move the mouse over the Workspace Switcher applet in the bottom panel, and scroll the mouse wheel.

•

Press Ctrl-Alt-right arrow to switch to the workspace on the right of the current workspace.

•

Press Ctrl-Alt-left arrow to switch to the workspace on the left of the current workspace.
The arrow shortcut keys work according to how your workspaces are set out in the Workspace Switcher applet. If you change your panel so workspaces are displayed vertically instead of horizontally, use
Ctrl-Alt-up arrow and Ctrl-Alt-down arrow to switch workspaces.

Adding Workspaces
To add workspaces to the GNOME Desktop, right-click on the Workspace Switcher applet, then choose Preferences.
The Workspace Switcher Preferences dialog is displayed. Use the Number of workspaces spin box to specify the
number of workspaces that you require.
For more on this, see the Workspace Switcher Applet Manual.

Applications
An application is a type of computer program that allows you to perform a particular task. You might use applications to create text documents such as letters or reports; to work with spreadsheets; to listen to your favorite music;
to navigate the Internet; or to create, edit, or view images and videos. For each of these tasks, you would use a different application.
To launch an application, open the Applications menu and choose the application you want from the submenus. For
more on this, see the section called “Applications Menu”.
The applications that are part of GNOME include the following:
•

Gedit Text Editor can read, create, or modify any kind of simple text without any formatting.

•

Dictionary allows you to look up definitions of a word.

•

Image Viewer can display single image files, as well as large image collections.

•

Calculator performs basic, financial, and scientific calculations.

•

Character Map lets you choose letters and symbols from the Unicode character set and paste them into any application. If you are writing in several languages, not all the characters you need will be on your keyboard.

•

Nautilus File Manager displays your folders and their contents. Use this to copy, move, classify your files; and
14
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access CDs, USB flashdrives, or any removable media. When you choose an item from the Places menu, a
Nautilus File Manager window opens you show you that location.
•

Terminal gives you access to the system command line.

Further standard GNOME applications include games, music and video players, a web browser, software accessibility tools, and utilities to manage your system. Your distributor or vendor may have added other GNOME applications, such as a word processor and a graphics editor. Your distributor or vendor may also provide you with a way to
install further applications.
All GNOME applications have many features in common, which makes it easier to learn how to work with a new
GNOME application. The rest of this section describes some of these features.

Common Features
The applications that are provided with the GNOME Desktop share several characteristics. For example, the applications have a consistent look-and-feel. The applications share characteristics because the applications use the same
programming libraries. An application that uses the standard GNOME programming libraries is called a GNOMEcompliant application. For example, Nautilus and the gedit text editor are GNOME-compliant applications.
GNOME provides libraries in addition to the libraries provided by your operating system. The libraries enable
GNOME to run your existing applications as well as GNOME-compliant applications. For example, if your operating system is UNIX-based, you can run your current X11 applications and Motif applications from the GNOME
Desktop.
Some of the features of GNOME-compliant applications are as follows:
•

Consistent look-and-feel
GNOME-compliant applications have a consistent look-and-feel. GNOME-compliant applications use the lookand-feel settings that you specify in the preference tools. You can use the following tools to change the lookand-feel of your GNOME-compliant applications:

•

•

Menus & Toolbars preference tool

•

Theme preference tool

Menubars, toolbars, and statusbars
Most GNOME-compliant applications have a menubar, a toolbar, and a statusbar. The menubar always contains
a File menu and a Help menu. The File menu always contains an Quit menu item, and the Help menu always
contains an About menu item.
A toolbar is a bar that appears under the menubar. A toolbar contains buttons for the most commonly-used commands. A statusbar is a bar at the bottom of a window that provides information about the current state of what
you are viewing in the window. GNOME-compliant applications might also contains other bars. For example,
Nautilus contains a location bar.
Some of the bars in GNOME-compliant applications are detachable. That is, the bar has a handle that you can
grab then drag the bar to another location. You can drag the bar to snap to another side of the window, or to another part of the screen. For example, you can detach the menubar, toolbar, and location bar in the file manager.

•

Default shortcut keys
GNOME-compliant applications use the same shortcut keys to perform the same actions. For example, to quit a
GNOME-compliant application, press Ctrl-Q. To undo an action in a GNOME-compliant application, press
Ctrl-Z.

•

Drag-and-drop
GNOME-compliant applications use the same protocol to implement drag-and-drop operations. Therefore,
GNOME-compliant applications provide consistent feedback when you drag-and-drop items.
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The use of the same protocol also enables GNOME-compliant applications to interoperate in a sophisticated
manner. For example, GNOME-compliant applications recognize the format of the items that you drag. When
you drag a HTML file from a Nautilus window to a web browser, the file is displayed in HTML format in the
browser. However, when you drag the HTML file to a text editor, the file is displayed in plain text format in the
text editor.

Working With Files
The work you do with an application is stored in files. These may be on your computer's hard drive, or on a removable device such as a USB flashdrive. You open a file to examine it or work on it, and you save a file to store your
work. When you are done working with a file, you close it.
All GNOME applications use the same dialogs for opening and saving files, presenting you with a consistent interface. The following sections cover the open and the save dialog in detail.

Choosing a File to Open
The Open File dialog allows you to choose a file to open in an application.
The right-hand pane of the dialog lists files and folders in the current location. You can use the mouse or the arrow
keys on your keyboard to select a file.
Once a file is selected in the list, perform one of the following actions to open it:
•

Click Open.

•

Press Return.

•

Press Spacebar.

•

Double-click the file.

If you open a folder or a location instead of a file, the Open File dialog updates to show the contents of that folder or
location.
To change the location shown in the right-hand pane, do one of the following:
•

Open a folder that is listed in the current location.

•

Open an item in the left-hand pane. This pane lists places such as your Documents folder, your Home Folder,
media such as CDs and flashdrives, places on your network, and your bookmarks.

•

Click one of the buttons in the path bar above the file listing pane. This shows the hierarchy of folders that contain your current location. Use the arrow buttons to either side of the button bar if the list of folders is too long to
fit.

The lower part of the Open File dialog may contain further options specific to the current application.

Filtering the File List
You can restrict the file list to show only files on certain types. To do this, choose a file type from the drop-down list
beneath the file list pane. The list of file types depends on the application you are currently using. For example, a
graphics application will list different image file formats, and a text editor will list different types of text file.

Find-as-you-type
If you know the name of the file you want to open, begin typing it: the file list will jump to show you files whose
names begin with the characters you type. Arrow keys will now select from only these files. The characters you have
typed appear in a pop-up window at the base of the file list.
16

Chapter 2. Desktop Overview

Applications

To cancel find-as-you-type, press Esc.

Open Location
To enter the full path to a file you want to open, press Ctrl-L or right-click in the right-hand pane and choose Open
Location. This opens the Open Location dialog.
Type a path from the current location, or an absolute path beginning with / or ~/. The Location field has the following features to simplify the typing of a full filename:
•

A drop-down of possible file and folder names is displayed once you begin typing. Use down arrow and up arrow and Return to choose from the list.

•

If the part of the name typed uniquely identifies a file or folder, the name is auto-completed. Press Tab to accept
the suggested text. For example, if you type "Do", and the only object in the folder beginning with "Do" is Documents, then the entire name appears in the field.

Adding and Removing Bookmarks
To add the current location to the bookmarks list, press Add, or right-click a folder in the file list and choose Add to
Bookmarks.
To remove a bookmark from the list, select it and press Remove.
Changes you make to the bookmarks list also affect the Places menu. For more on bookmarks, see the
section called “Using Bookmarks For Your Favorite Locations”.

Showing hidden files
To show hidden files in the file list, right-click in the file list and choose Show Hidden Files. For more on hidden
files, see the section called “Hiding a File or Folder”.

Saving a File
The first time you save your work in an application, the Save File dialog will ask you for a location and name for the
new file. Subsequent saving updates this file. To save to a new file, choose File→Save As.
You can enter a filename and choose a location to save in from the drop-down list of bookmarks and commonlyused locations.

Saving in another location
To save the file in a location not listed in the drop-down list, click the Browse for other folders expansion label. This
shows a file browser similar to the one in the Open File dialog.
The expanded Save File dialog has the same features as the Open File dialog, such as filtering, findas-you-type, and adding and removing bookmarks.

Typing a Path
To specify a path to save a file, type it into the Name field. A drop-down of possible file and folder names is displayed once you begin typing. Use down arrow and up arrow and Return to choose from the list. If only one file
or folder matches the partial name you have typed, press Tab to complete the name.
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Starting a Session

Needs better intro
This chapter needs work
This chapter provides the information you need to log in to and shut down GNOME, and to start, manage, and end a
desktop session.

Starting a Session
A session is the period of time you spend using GNOME. During a session, you use your applications, print, browse
the web, and so on.
Logging in to GNOME begins your session. The login screen is your gateway to the GNOME Desktop: it is where
you enter your username and password and select options such as the language you want GNOME to use for your
session.
Normally, logging out ends the session, but you can choose to save the state of your session and restore
it next time you use GNOME: see the section called “Sessions Preferences”.

Logging in to GNOME
To log in to a session, perform the following steps:
1.

On the login screen, click on the Session icon. Choose the GNOME Desktop from the list of available desktop
environments.

2.

Enter your username in the Username field on the login screen, then press Return.

3.

Enter your password in the Password field on the login screen, then press Return.

When you log in successfully, you will see a splash informing you of the steps GNOME is taking to start up. When
GNOME is ready, you will see the Desktop and you can begin using your computer.
The first time you log in, then the session manager starts a new session. If you have logged in before, then the session manager restores your previous session, if you saved the settings for the previous session when you logged out.
If you want to shut down or restart the system before you log in, click on the System icon on the login screen. A dialog is displayed. Select the option that you require, then click OK.

Using a Different Language
To log in to a session in a different language, perform the following actions.
1.

On the login screen, click on the Language icon. Choose the language you require from the list of available languages.

2.

Enter your username in the Username field on the login screen, then press Return.

3.

Enter your password in the Password field on the login screen, then press Return.
When you log in to a session in a different language, you choose the language for the user interface.
You do not specify a keyboard layout for the session. To choose a keyboard layout, use the Keyboard
Indicator applet.
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Locking Your Screen

Locking your screen allows you to leave your computer unattended and prevent access to your applications and information. While your screen is locked, the screensaver runs.
To lock the screen, perform one of the following actions:
•

Choose Desktop→Lock Screen.

•

If the Lock Screen button is present on a panel, click on the Lock Screen button.
The Lock Screen is not present on the panels by default. To add it, see the section called “Adding
an Object to a Panel”.

To unlock the screen, move your mouse or press any key, enter your password in the locked screen dialog, then
press Return.

Managing the Session
To configure the session management of the GNOME Desktop, use the Sessions preference tool. The Sessions preference tool recognizes the following types of application:
•
Applications that are session-managed. When you save the settings for your session, the session manager saves
all of the session-managed applications. If you log out, then log in again, the session manager automatically
starts the session-managed applications.
•

Applications that are not session-managed. When you save the settings for your session, the session manager
does not save any applications that are not session-managed. If you log out, then log in again, the session manager does not start non-session-managed applications. You must start the application manually. Alternatively,
you can use the Sessions preference tool to specify non-session-managed applications that you want to automatically start.

Defining Session Behavior When You Log In and Log Out
To set how a session behaves when you log in and log out, use Sessions preference tool. Make the changes you require in the Session Options tabbed section. For example, you can select to display a splash screen when you log in.

To Use Startup Applications
You can configure your sessions to start with applications that are not session-managed. To configure non-session-managed startup applications, use the Sessions preference tool. Use the Startup Programs tabbed section to add,
edit, and delete applications. If you save your settings and log out, the next time that you log in, the startup applications start automatically.
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To Browse Applications in the Current Session
To browse the applications in the current session, use the Sessions preference tool. The Current Session tabbed section lists the following:
•

All GNOME applications that are currently running, that can connect to the session manager, and that can save
the state of the application.

•

All preference tools that can connect to the session manager, and that can save the state of the tool.

You can use the Current Session tabbed section to perform a limited number of actions on the session properties of
an application or preference tool. For example, you can edit the startup order, and restart style of any GNOME application or preference tool that is in the list.

To Save Session Settings
To save your session settings, perform the following steps:
1.

Configure your session to automatically save settings when you end the session. To configure your session, use
the Sessions preference tool. The Sessions preference tool starts. Select the Automatically save changes to session option on the Session Options tabbed section.

2.

End your session.

Ending a Session
When you have finished using your computer, you can choose to do one of the following:
•

Log out for another user to begin working with it. To log out of GNOME, choose Desktop→Log Out username .

•

Shut down your computer and switch off the power. To shut down, choose Desktop→Shut Down.

•

Depending on your computer's configuration, you can also Hibernate your computer. During hibernation, less
power is used, but the state of your computer is preserved: all the applications you have running and open documents.

When you end a session, applications with unsaved work will warn you. You can choose to save your work, or cancel the command to log out or shut down.
Before you end a session, you might want to save your current settings so that you can restore the session later. In
the Sessions preference tool, you can select an option to automatically save your current settings.
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Introduction

This chapter describes how to use the panels at the top and bottom of the GNOME Desktop, how to customize the
objects that appear on them, and how to add new panels to the desktop.

Introduction
A panel is an area in the GNOME Desktop where you have access to certain actions and information, no matter what
the state of your application windows. For example, in the default GNOME panels, you can launch applications, see
the date and time, control the system sound volume, and more.
You can customize panels to your liking. You can change their behavior and appearance, and you can add or remove
objects from your panels. You can create multiple panels, and choose different properties, objects, and backgrounds
for each panel. You can also hide panels.
By default, the GNOME Desktop contains a panel at the top edge of the screen, and a panel at the bottom edge of
the screen. The following sections describe these panels.

Top Edge Panel
By default, the top edge panel contains the following objects:
Your distribution of GNOME may have altered this default setup.
Menu Bar applet
Contains the Applications, the Places, and the Desktop menu. For more on the menu bar, see Chapter 5,
Menubar.
Web Browser Launcher
Click on this launcher to open the web browser.
Notification Area applet
Displays icons from other applications that may require your attention, or that you may want to access without
switching from your current application window. For more on this, see the section called “Notification Area
Applet”.
Until an application adds an icon to the notification area, only a narrow bar is visible.
Clock applet
Clock shows the current time. Click on the time to open a small calendar. For more on this, see the Clock Applet Manual.
Volume Control applet
Volume Control enables you to control the volume of the speaker on your system. For more on this, see the
Volume Control Manual.
Window Selector icon
Window Selector lists all your open windows. To give focus to a window, click on the window selector icon at
the extreme right of the top edge panel, then select the window. For more on this, see the section called “Giving
Focus to a Window”.
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Bottom Edge Panel
By default, the bottom edge panel contains the following objects:
Your distribution of GNOME may have altered this default setup.
Show Desktop button
Click on this button to minimize all open windows and show the desktop.
Window List applet
Displays a button for each window that is open. Window List enables you to minimize and restore windows.
For more on this, see the Window List manual.
Workspace Switcher applet
Enables you to switch between your workspaces. For more on workspaces, see the section called “Workspaces”.

Managing Panels
The following sections describe how to manage your panels.
To interact with a panel, you must click on the vacant space on the panel, rather than any of the objects it holds. You
can also middle-click or right-click on one of the hide buttons to select the panel, if the panel has no vacant space. If
the hide buttons are not visible on a panel, modify the properties of the panel so that the hide buttons are visible.

Moving a Panel
Drag a panel to another side of the screen to move it there. Click on any vacant space on the panel to begin the drag.
A panel that is not set to expand to the full width of the screen can be dragged away from the edge of the screen and
placed anywhere. See the section called “Panel Properties” for details on how to set a panel's expand property.

Panel Properties
You can change the properties of each panel, such as the position of the panel, the hide behavior, and the visual appearance.
To modify the properties of a panel, right-click on a vacant space on the panel, then choose Properties. The Panel
Properties dialog contains two tabbed sections, General and Background.

General Properties Tab
In the General tab, you can modify panel size, position, and hiding properties. The following table describes the dialog elements on the General tabbed section:
Dialog Element

Description

Orientation

Select the position of the panel on your screen. Click on the required position for
the panel.

Size

Use the spin box to specify the size of the panel.

Expand

By default, a panel expands to the full length of the edge of the screen where it is
located. A panel that does not expand can be moved away from the screen edges to
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Description
any part of the screen.

Autohide

Select this option if you want the panel to only be fully visible when the mouse
pointer is over it. The panel hides off-screen along its principal edge, leaving a
narrow part along the edge of the desktop. Move the mouse pointer over the visible part of the panel to make it move fully into the screen.

Show hide buttons

Select this option to display hide buttons at each end of your panel. Clicking on a
hide button moves the panel lenthways, hiding it off-screen except for the hide
button at the opposite end. Click this hide button to restore the panel to being fully
visible.

Arrows on hide button

Select this option to display arrows on the hide buttons, if the hide button is enabled.

Background Properties Tab
You can choose the type of background for the panel in the Background tab. The choices are as follows:
Dialog Element

Description

None (use system theme)

Select this option to have the panel use the settings in the Theme preference
tool. This keeps your panel's background looking the same as the rest of the
desktop and applications.

Solid color

Select this option to specify a single color for the panel background. Click on
the Color button to display the color selector dialog. Choose the color that you
require from the color selector dialog.
Use the Style slider to specify the degree of transparency or opaqueness for
the color. For example, to make the panel transparent, move the slider to the
Transparent end.

Background image

Select this option to specify an image for the panel background. Click on the
button to browse for the file. When you have selected the file, click OK.

You can also drag a color or image on to a panel to set the color or image as the background of the panel. You can
drag a color or image from many applications. For example:
•

You can drag a color from any color selector dialog.

•

You can drag an image file from the Nautilus file manager to set it as the background of the panel.

•

You can drag a color or a pattern from the Backgrounds and Emblems dialog in Nautilus file manager to a panel
to set it as the background.

Click Close to close the Panel Properties dialog.
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Hiding a Panel
You can hide or show panels. To hide a panel, use a hide button. If the hide buttons are not visible on a panel, modify the panel properties so that the hide buttons are visible.
Hide buttons are at either end of a panel. The hide buttons contain an optional arrow icon. The following illustration
shows hide buttons.

To hide a panel, click on one of the hide buttons. The panel reduces in the direction of the arrow on the hide button.
The hide button at the other end of the panel remains visible.
To show a hidden panel again, click on the visible hide button. The panel expands in the direction of the arrow on
the hide button. Both hide buttons are now visible.
You can set a panel to autohide. When you set autohide, the panel hides automatically when the mouse is not pointing to the panel. The panel reappears when you point to the part of the screen where the panel resides. To set your
panel to autohide, modify the properties of the panel.

Adding a New Panel
To add a panel, right-click on a vacant space on any panel, then choose New Panel. The new panel is added to the
GNOME Desktop. The new panel contains no objects. You can customize the new panel to suit your preferences.

Deleting a Panel
To delete a panel from the GNOME Desktop, right-click on the panel that you want to delete, then choose Delete
This Panel.
You must always have at least one panel in the GNOME Desktop. If you have only one panel in the
GNOME Desktop, you cannot delete that panel.

Panel Objects
This section describes the objects that you can add to your panels, and use from your panels.

Interacting With Panel Objects
You use the mouse buttons to interact with a panel object in the following ways:
Left-click
Launches the panel object.
Middle-click
Enables you to grab an object, then drag the object to a new location.
Right-click
Opens the panel object popup menu.
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To Select an Applet
Some restrictions apply on where you can click on an applet in order to display the panel object popup menu, or to
move the applet, as follows:
•

Some applets have popup menus of applet-specific commands that open when you right-click on particular parts
of the applet. For example, the Window List applet has a vertical handle on the left side, and buttons that represent your windows on the right side. To open the panel object popup menu for the Window List applet, you must
right-click on the handle. If you right-click on a button on the right side, a popup menu for the button opens.

•

Some applets have areas that you cannot use to select the applet. For example, the Command Line applet has a
field in which you enter commands. You cannot middle-click or right-click on this field to select the applet. Instead, middle-click or right-click on another part of the applet.

Adding an Object to a Panel
To add an object to a panel, perform the following steps:
1.

Right-click on a vacant space on a panel to open the panel popup menu.

2.

Choose Add to Panel.
The Add to Panel dialog opens.The available panel objects are listed alphabetically, with launchers at the top.
You can type a part of the name or description of an object in the find box. This will narrow the
list to those objects that match what you type.
To restore the full list, delete the text in the find box.

3.

Either drag an object from the list to a panel, or select an object from the list and click Add to add it at the spot
on the panel where you first right-clicked.

You can add also add any item in the Applications menu to the panel: right-click the menu item and choose Add this
launcher to panel.
Each launcher corresponds to a .desktop file. You can drag the .desktop file on to your panels to add the
launcher to the panel.

Modifying the Properties of an Object
Some panel objects, such as launchers and drawers, have a set of associated properties. The properties are different
for each type of object. The properties specify details such as the following:
•

The command that starts a launcher application.

•

The location of the source files for a menu.

•

The icon that represents the object.
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To modify the properties of an object perform the following steps:
1.
Right-click on the object to open the panel object popup menu, as shown in Figure 4.1, “Panel Object Popup
Menu”.

Figure 4.1. Panel Object Popup Menu

2.

Choose Properties. Use the Properties dialog to modify the properties as required. The properties in the Properties dialog depend on which object you select in step 1.

3.

Click OK to apply the changes, then close the Properties dialog.

Moving a Panel Object
You can move panel objects within a panel, and from one panel to another panel. You can also move objects
between panels and drawers.
To move a panel object, middle-click and hold on the object and drag the object to a new location. When you release
the middle mouse button, the object anchors at the new location.
Alternatively, you can use the panel object popup menu to move an object, as follows:
1.

Right-click on the object, then choose Move.

2.

Point to the new location for the object, then click any mouse button to anchor the object to the new location.
This location can be on any panel that is currently in the GNOME Desktop.

Movement of a panel object affects the position of other objects on the panel. To control how objects move on a
panel, you can specify a movement mode. To specify the movement mode, press one of the following keys as you
move the panel object:
Key

Movement Mode

Description

No key

Switched movement

The object swaps places with other panel objects. Switched
movement is the default movement mode.

Alt key

Free movement

The object jumps over other panel objects into the next vacant
space on the panel.

Shift key

Push movement

The object pushes other panel objects further along the panel.
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Locking a Panel Object
You can lock panel objects so that the objects stay in the same position on the panel. This feature is useful if you do
not want some panel objects to change position when you move other panel objects.
To lock an object to the current location of the object in the panel, right-click on the object to open the panel object
popup menu, then choose Lock. To unlock the object, right-click on the object, then choose Unlock.

Removing a Panel Object
To remove an object from a panel right-click on the object to open the panel object popup menu, then choose Remove From Panel.

Applets
An applet is a small application whose user interface resides within a panel. You use the applet panel object to interact with the applet. For example, the following figure shows the following applets, from left to right:
•

Window List: Displays the windows currently open on your system.

•

CD Player: Enables you to control the compact disc player on your system.

•

Volume Control: Enables you to control the volume of the speaker on your system.

Launchers
A launcher is an object that performs a specific action when you open it.
You can find launchers in the panels, in the Main Menubar, and on the desktop. A launcher is represented by an icon
in all of these locations.
You might use a launcher to do any of the following:
•

Start a particular application.

•

Execute a command.

•

Open a folder.

•

Open a Web browser at a particular page on the Web.

•

Open special Uniform Resource Identifiers (URIs). The GNOME Desktop contains special URIs that enable you
to access particular functions from the file manager.

You can modify the properties of a launcher. For example, the properties of a launcher include the name of the
launcher, the icon that represents the launcher, and how the launcher runs. For more on this, see the section called
“Modifying a Launcher”.
In certain situations, a launcher in a menu might not show an icon. For example, if it specifies no icon
to display, or if the entire menu is set to show no icons.
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Adding a Launcher to a Panel
You can add a launcher to a panel in one of the following ways:
•

From the panel popup menu
Right-click on any vacant space on the panel, then choose Add to Panel. The Add to Panel dialog opens.
To create a new launcher, select Custom Application Launcher from the list. A Create Launcher dialog is displayed. For more information on the properties in this dialog, see the section called “Launcher Properties”.
Alternatively, to add an existing launcher to the panel, select Application Launcher from the list. Choose the
launcher that you want to add from the list of menu items.

•

From any menu
To add a launcher to a panel from any menu, perform one of the following steps:

•

•

Open a menu that contains the launcher. Drag the launcher on to the panel.

•

Open the menu that contains the launcher from the panel where you want the launcher to reside. Right-click
on the title of the launcher. Choose Add this launcher to panel.

From the file manager
To add a launcher to a panel from the file manager, find the .desktop file for the launcher in your file system,
then drag the .desktop file to the panel.

Modifying a Launcher
To modify the properties of a launcher in a panel, perform the following steps:
1.

Right-click on the launcher to open the panel object popup menu.

2.

Choose Properties. Use the Launcher Properties dialog to modify the properties as required. For more information on the Launcher Properties dialog, see the section called “Launcher Properties”.

3.

Click Close to close the Launcher Properties dialog.

Launcher Properties
You can set a number of properties for a launcher, whether you are creating a launcher, or modify an existing one.
The following table describes the dialog elements on the Basic tabbed section:
Dialog Element

Description

Name

Use this text box to specify the name of the launcher. You can use the Advanced tab
to add translations of the name. This name is the name that appears when you add the
launcher to a menu or to the desktop.

Generic name

Use this text box to specify the class of application to which the launcher belongs.
For example, you might type Text Editor in this text box for a gedit launcher.
You can use the Advanced tab to add translations of the generic name.

Comment

Use this text box to specify a short description of the launcher. The comment is displayed as a tooltip when you point to the launcher icon on the panel. You can use the
Advanced tabbed section to add translations of the comment.
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Dialog Element

Description

Command

Use this field to specify a command to execute when you click on the launcher. For
sample commands, see the next section.

Type

Use this drop-down combination box to specify the type of launcher. Select from the
following:
•

Application: Select this option to create a launcher that starts an application.

•

Link: Select this option to create a launcher that links to a URI.

Icon

Choose an icon to represent the launcher. To choose an icon, click on the No Icon
button. An icon selector dialog is displayed. Choose an icon from the dialog. Alternatively, to choose an icon from another directory, click Browse. When you choose an
icon, click OK.

Run in terminal

Select this option to run the application or command in a terminal window. Choose
this option for an application or command that does not create a window in which to
run.

The following table describes the dialog elements on the top part of the Advanced tabbed section:
Dialog Element

Description

Try this before using

Enter a command here to check before starting the launcher. If the command is
executable and is in your path, the launcher appears on the panel.

Documentation

Enter the path to the help file for the launcher. If you enter a path in this field,
a Help on launcher-name Application menu item is displayed on the
popup menu for the launcher.

You can also add a translation of the Name, Generic name, and Comment fields from the Basic tabbed section. To
add a translation, enter the details of the translation in the Name/Comment translations table as follows:
Field

Description

First field

Enter the two-letter code for the language for which you want to add a translation.

Second field

Enter the translation of the Name of the launcher.

Third field

Enter the translation of the Generic name of the launcher.

Fourth field

Enter the translation for the Comment for the launcher.

Then click on the Add/Set button.
To edit a translation, select the translation. The translated text appears in the lower part of this dialog. Edit the fields
as required, then click on the Add/Set button.
To remove a translation, select the translation, then click on the Remove button.

31

Chapter 4. Working With Panels

Buttons

Launcher Commands
The type of commands that you can enter in the Command field depend on the option that you choose from the Type
drop-down combination box. If you choose Application from the Type drop-down combination box, you can enter a
normal command. The following table shows some sample commands and the actions that the commands perform:
Sample Application Command

Action

gedit

Starts the gedit text editor application.

gedit /user123/loremipsum.txt

Opens the file /user123/loremipsum.txt in the gedit
text editor application.

nautilus /user123/Projects

Opens the folder /user123/Projects in a file object
window.

If you choose Link from the Type drop-down combination box, you can enter a link command. The following table
shows some sample link commands and the actions that the commands perform:
Sample Link Command

Action

http://www.gnome.org

Opens the GNOME website in your default browser.

ftp://ftp.gnome.org

Opens the GNOME FTP site in your default browser.

Buttons
You can add buttons to your panels to provide quick access to common actions and functions.

Force Quit Button

The Force Quit button enables you to select a window to terminate an application. This button is useful if you want
to terminate an application that does not respond to your commands.
To terminate an application, click on the Force Quit button, then click on a window from the application that you
want to terminate. If you do not want to terminate an application after you click on the Force Quit button, press Esc.

Lock Screen Button

The Lock Screen button locks your screen and activates your screensaver. To access your session again, you must
enter your password.
To add a Lock Screen button to a panel, right-click on any vacant space on the panel. Choose Add to Panel, then
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choose Lock Screen from the Add to Panel dialog. See the section called “Adding an Object to a Panel” for more on
this.
Right-click on the Lock Screen button to open a menu of screensaver-related commands. Table 4.1, “Lock Screen
Menu Items” describes the commands that are available from the menu.

Table 4.1. Lock Screen Menu Items
Menu Item

Function

Activate Screensaver

Activates the screensaver immediately.
This will also lock the screen if you have set Lock screen when
screensaver is active in the Screensaver preference tool.

Lock Screen

Locks the screen immediately. This command performs the same
function as when you click on the Lock Screen button.

Properties

Opens the Screensaver preference tool, with which you can configure the type of screensaver that is displayed when you lock the
screen.

Log Out Button

The Log Out button begins the process to log out of a GNOME session.
To add a Log Out button to a panel, right-click on any vacant space on the panel. Choose Add to
Panel→Actions→Log Out. To log out of your session or shut down your system, click on the Log Out button.

Run Button

You can use the Run button to open the Run Application dialog.
To add a Run button to a panel, right-click on any vacant space on the panel. Choose Add to Panel→Actions→Run.
To open the Run Application dialog, click on the Run button.
For more information on the Run Application dialog, see Working With Menus.
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Screenshot Button

You can use the Screenshot button to take a screenshot of your screen.
To add a Screenshot button to a panel, right-click on any vacant space on the panel. Choose Add to
Panel→Actions→Screenshot. To take a screenshot of your screen, click on the Screenshot button.
For more information on how to take screenshots, see Working With Menus.

Search Button

You can use the Search button to open the Search Tool.
To add a Search button to a panel, right-click on any vacant space on the panel. Choose Add to
Panel→Actions→Search. To open the Search Tool, click on the Search button.
For more information on the Search Tool, see the Search Tool Manual.

Show Desktop Button

You can use the Show Desktop button to minimize all open windows and show the desktop.
To add a Show Desktop button to a panel, right-click on any vacant space on the panel. Choose Add to Panel→Actions→Show Desktop. To minimize all windows and show the desktop, click on the Show Desktop button.

Menus
You can add the following types of menu to your panels:
•

Main Menu: You can access almost all of the standard applications, commands, and configuration options from
the Main Menu. To add a Main Menu to a panel, right-click on any vacant space on the panel, then choose Add
to Panel→Main Menu. You can add as many Main Menu objects to your panels as you want.

•

Menu Bar: You can access almost all of the standard applications, commands, and configuration options from
the menus in the Menu Bar. The Menu Bar contains the Applications menu and the Actions menu. To add a
Menu Bar to a panel, right-click on any vacant space on the panel, then choose Add to Panel→Menu Bar. You
can add as many Menu Bar objects to your panels as you want.

•

System menus: System menus contain the standard applications and tools that you can use in the GNOME
Desktop. The Applications menu and Actions menu are system menus. To add a system menu to a panel, rightclick on a launcher in the menu, then choose Entire menu→Add this as menu to panel.

34

Chapter 4. Working With Panels

Drawers

Drawers
A drawer is an extension of a panel. You can open and close a drawer in the same way that you can show and hide a
panel. A drawer can contain all panel objects, including launchers, menus, applets, other panel objects, and other
drawers. When you open a drawer, you can use the objects in the same way that you use objects on a panel.
The following figure shows an open drawer that contains two panel objects.

The arrow on the drawer icon indicates that the icon represents a drawer or menu.
You can add, move, and remove objects from drawers in the same way that you add, move, and remove objects from
panels.

To Open and Close a Drawer
To open a drawer, click on the drawer object in a panel. You can close a drawer in the following ways:
•

Click on the drawer.

•

Click on the drawer hide button.

To Add a Drawer to a Panel
You can add a drawer to a panel in the following ways:
•

From the panel popup menu
Right-click on any vacant space on the panel, then choose Add to Panel→Drawer.

•

From any menu
You can add a menu as a drawer object to a panel.
To add a menu as a drawer to a panel, open the menu from the panel. Right-click on any launcher in the menu,
then choose Entire menu→Add this as drawer to panel.

To Add an Object to a Drawer
You add an object to a drawer in the same way that you add objects to panels. For more information, see the section
called “Adding an Object to a Panel”.
35

Chapter 4. Working With Panels

Default Panel Objects

To Modify Drawer Properties
You can modify properties for each individual drawer. You can change features for each drawer, such as the visual
appearance of the drawer and whether the drawer has hide buttons.
To modify properties for a drawer perform the following steps:
1.

Right-click on the drawer, then choose Properties to display the Panel Properties dialog. The dialog displays the
General tabbed section.

2.

Select the properties for the drawer in the dialog. The following table describes the elements on the General
tabbed section:

Dialog Element

Description

Name

Type a name for the panel. When you use shortcut keys to switch between your
panels and the desktop, this panel name is displayed.

Size

Select the size of the panel.

Icon

Choose an icon to represent the drawer. Click on the Icon button to display an icon
selector dialog. Choose an icon from the dialog. Alternatively, click Browse to
choose an icon from another directory. When you choose an icon, click OK.

Show hide buttons

Select this option to display hide buttons on your panel.

Arrows on hide button

Select this option to display arrows on the hide buttons, if the hide button is enabled.

3.

You can use the Background tabbed section to set the background for the drawer. For information on how to
complete the Background tabbed section, see the step on this topic in the section called “Panel Properties”. You
can also drag a color or image on to a drawer to set the color or image as the background of the drawer. For
more information, see the section called “Background Properties Tab”.

4.

Click Close to close the Panel Properties dialog.

Default Panel Objects
This section covers the panel objects that appear in the default GNOME desktop.

Window Selector Applet
You can view a list of all windows that are currently open. You can also choose a window to give focus to. To view
the window list, click on the Window Selector applet. The following figure shows an example of the Window Selector applet:
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To give focus to a window, select the window from the Window Selector applet.
The Window Selector lists the windows in all workspaces. The windows in all workspaces other than the current
workspace, are listed under a separator line.

Notification Area Applet

The Notification Area applet displays icons from various applications to indicate activity in the application. For example, when you use the CD Player application to play a CD, a CD icon is displayed in the Notification Area applet.
The graphic above illustrates the CD icon in the Notification Area applet.
To add a Notification Area applet to a panel, right-click on any vacant space on the panel. Choose Add to
Panel→Utility→Notification Area.

Main Menu panel object
The Main Menu provides access to the Applications menu and many of the items in the Actions menu. You can access almost all of the standard applications, commands, and configuration options from the Main Menu.
You can add Main Menu buttons to your panels. Click on the Main Menu button to open the Main Menu.

To Add a Main Menu to a Panel
You can add as many Main Menu buttons as you want to your panels. To add a Main Menu to a panel, right-click on
any vacant space on the panel. Choose Add to Panel→Main Menu.

Menu Bar panel object
The Menu Bar provides access to the Applications and Actions menus. You can access almost all of the standard applications, commands, and configuration options from the Menu Bar. For more on using the Menu Bar, see
Chapter 5, Menubar.

To Add a Menu Bar to a Panel
You can add as many Menu Bar applets as you want to your panels. To add a Menu Bar to a panel, right-click on
any vacant space on the panel. Choose Add to Panel→Menu Bar.
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This chapter describes how to use the GNOME Desktop Menubar.
The menubar at the top of the GNOME Desktop, in the Top Edge Panel, is your main point of access to GNOME.
Use the Applications menu to launch applications, the Places to open locations on your computer or network, and
the Desktop to customize your system, get help with GNOME, and log out of GNOME or shut down your computer.
The following sections describe these three menus.
The menubar is in fact a panel object: you can move the menubar to another panel, or have more than
one instance of the menubar in your panels. For more on this, see the section called “Menus”.

Applications Menu
The Applications menu contains a hierarchy of submenus, from which you can start the applications that are installed on your system.
Each submenu correponds to a category. For example, in the Sound & Video submenu, you will find applications for
playing CDs and recording sound.
To launch an application, perform the following steps:
1.

Open the Applications menu by clicking on it.

2.

Move the mouse down the menu to the category the application you want is in. Each submenu opens as your
mouse passes over the category.

3.

Click the menu item for the application.

When you install a new application, it is automatically added to the Applications menu in a suitable category. For
example, if you install an instant messenger application, a VoIP application, or an FTP client, you will find it in the
Internet submenu.

Places Menu
The Places menu is a quick way to go to various locations on your computer and your local network. The Places
menu allows you to open the following items:
•

Your Home folderAdd link!

•

The Desktop folder, which corresponds to the items displays in the desktop.

•

The items in your Nautilus bookmarks. For more on this, see the section called “Using Bookmarks For Your Favorite Locations”.

•

Your computer, which shows all your drives.

•

The Nautilus CD/DVD Creator. For more on this, see the section called “Writing CDs or DVDs”.

•

The local network. For more on this, see the section called “To Access Network Places”.

The last three items on the menu perform actions rather than open locations.
•

Connect to Server lets you choose a server on your network. For more on this, see the section called “To Access
a remote server”.

•

Search for Files lets you search for files on your computer. For more on this, see the Search for Files Manual.

•

The Recent Documents submenu lists the documents you have recently opened. The last entry in the submenu
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clears the list.

Desktop Menu
The Desktop menu allows you to set your preferences for the GNOME Desktop, get help with using GNOME, and
log out or shut down.
•

The Administration submenu contains tools to manage your computer. These all require your system's password.

•

The Preferences submenu contains all the preference tools. With these you can configure your GNOME
Desktop. For more on preference tools, see Chapter 8, Configuring Your Desktop.

•

The Help item launches the Help Browser.

•

The About GNOME item has a brief introduction to GNOME, links to the GNOME website, and credits.

•

The Lock Screen command starts your screensaver, and requires your password to return to the desktop. For
more on this, see the section called “Locking Your Screen”.

•

Choose Log Out to log out of GNOME, or to switch user.

•

Choose Shut Down to end your GNOME session and turn off your computer, or restart it.

For more on logging out and shutting down, see the section called “Ending a Session”.

Customizing Your Menus
You can modify the contents of the following menus:
•

Applications menu

•

Desktop Preferences menu

You use the following GNOME Desktop components to customize menus:
•

Menus on panels

•

Nautilus file manager

When you use panels to customize your menus, you use the menu item popup menu. For more information, see
Chapter 5, Menubar.
When you use the file manager to customize your menus, you must access the Applications menu or the Desktop
Preferences menu from within the file manager. To access the Applications menu or the Desktop Preferences menu,
open a file manager window.
To access menus in the file manager, access one of the following URIs in the file manager:
Menu

Enter this URI

Applications menu

applications:///

Desktop Preferences menu

preferences:///

For more information on the file manager, see Nautilus File Manager.
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To Add a Menu
To add a menu, perform the following steps:
1.

In a file manager window, access the location where you want to add the menu. For example, if you want to
add a menu to the Applications menu, enter applications:/// URI.

2.

Choose File→Create Folder. An untitled folder is added to the menu. The name of the folder is selected.

3.

Type a name for the folder, then press Return.

The next time that you log out then log in again, the menu is in the assigned location.

To Add a Launcher to a Menu
To add a launcher to a menu, perform the following steps:
1.

Right-click on any item in the menu to which you want to add the launcher.

2.

Choose Entire menu→Add new item to this menu. A Create Launcher dialog is displayed.

3.

Enter the properties of the launcher in the Create Launcher dialog. For more information on the elements in the
Create Launcher dialog, see Working With Panels.

4.

Click OK.

To Add a Launcher to an Empty Menu
To add a launcher to an empty menu, perform the following steps:
1.

In a file manager window, access the menu where you want to add the launcher.

2.

Choose File→Create Launcher. A Create Launcher dialog is displayed.

3.

Enter the properties of the launcher in the Create Launcher dialog. For more information on the elements in the
Create Launcher dialog, see Working With Panels.

4.

Click OK.

To Copy a Launcher to a Menu
To copy an existing launcher to a menu, perform the following steps:
1.

In a file manager window, access the location from which you want to copy the launcher. For example, if you
want to copy a launcher from the Applications menu, enter applications:/// URI.

2.

Select the launcher that you want to copy, then choose Edit→Copy File.

3.

In a file manager window, access the location to which you want to copy the launcher.

4.

Choose Edit→Paste Files. The launcher is added to the new location.

Alternatively, you can drag the launcher from one location to another.
The next time that you log out then log in again, the launcher is in the new menu location.

41

Chapter 5. Menubar

Customizing Your Menus

To Edit the Properties of a Menu
To edit the properties of a menu, perform the following steps:
1.

Right-click on any item in the menu that you want to edit.

2.

Choose Entire menu→Properties. A Launcher Properties dialog is displayed.

3.

Modify the properties of the menu in the Launcher Properties dialog. For more information on the elements in
the Launcher Properties dialog, see Working With Panels.

4.

Click OK.

To Edit a Menu Item
To edit a menu item, perform the following steps:
1.

Right-click on the item that you want to edit.

2.

Choose Properties. A Launcher Properties dialog is displayed.

3.

Modify the properties of the launcher in the Launcher Properties dialog. For more information on the elements
in the Launcher Properties dialog, see Working With Panels.

4.

Click OK.

To Delete an Item from a Menu
To delete an item from a menu, use the menu item popup menu. To delete an item from a menu, perform the following steps:
1.

Right-click on the item that you want to delete.

2.

Choose Remove this item.
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Introduction

This chapter describes how to use the Nautilus file manager.

Introduction
File Manager Functionality
The Nautilus file manager provides a simple and integrated way to manage your files and applications. You can use
the file manager to do the following:
•

Create folders and documents

•

Display your files and folders

•

Search and manage your files

•

Run scripts and launch applications

•

Customize the appearance of files and folders

•

Open special locations on your computer

•

Write data to a CD or DVD

•

Install and remove fonts

The file manager lets you organize your files into folders. Folders can contain files and may also contain other
folders. Using folders can help you find your files more easily.
Nautilus also manages the desktop. The desktop lies behind all other visible items on your screen. The desktop is an
active component of the way you use your computer.
Every user has a Home Folder. The Home Folder contains all of the user's files. The desktop is another folder. The
desktop contains special icons allowing easy access to the users Home Folder, Trash, and also removable media
such as floppy disks, CDs and USB flashdrives.
Nautilus is always running while you are using GNOME. To open a new Nautilus window, double-click on an appropriate icon on the desktop such as Home or Computer, or choose an item from Places menu on the top panel.
In GNOME many things are files, such as word processor documents, spreadsheets, photos, movies, and music.

File Manager Presentation
Nautilus provides two modes in which you can interact with your filesystem: spatial and browser mode. You may
decide which method your prefer and set Nautilus to always use this by selecting (or deselecting) Always open in
browser windows in the Behavior tab of the Nautilus preferences dialog.
Spatial mode is the default in GNOME, but your distributor, vendor, or system administrator may have configured
Nautilus to use browser mode by default.
The following explains the difference between the two modes:
Browser mode: browse your files and folders
The file manager window represents a browser, which can display any location. Opening a folder updates the
current file manager window to show the contents of the new folder.
As well as the folder contents, the browser window displays a toolbar with common actions and locations, a location bar that shows the current location in the hierarchy of folders, and a sidebar that can hold different kinds
of information.
In Browser Mode, you typically have fewer file manager windows open at a time. For more information on us44
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ing browser mode see the section called “Browser Mode”.

Figure 6.1. Nautilus in browser mode.

Spatial mode: navigate your files and folders as objects
The file manager window represents a particular folder. Opening a folder opens the new window for that folder.
Each time you open a particular folder, you will find its window displayed in the same place on the screen and
the same size as the last time you viewed it (this is the reason for the name 'spatial mode').
Using spatial mode may lead to more open file manager windows on the screen. On the other hand, some users
find that representing files and folders as though they were real physical objects with particular locations makes
it easier to work with them. For more information on using spatial mode see the section called “Spatial Mode”

45

Chapter 6. Nautilus File Manager

Spatial Mode

Figure 6.2. Three Folders Opened in Spatial Mode.

Notice how, when in spatial mode, Nautilus indicates an open folder with a different icon.

Spatial Mode
The following section describes how to browse your system using the Nautilus file manager when configured in spatial mode. In spatial mode, each Nautilus window corresponds to a single folder. When you open a folder its window
appears at the same place on the screen as the last time you looked at it. This is the default behaviour in Nautilus.
For a comparison of browser mode and spatial mode, see the section called “File Manager Presentation”.

Spatial Windows
A new spatial window opens each time you open a folder. To open a folder, do one of the following:
•

Double-click the folder's icon on the desktop or an existing window

•

Select the folder, and press Ctrl-O.
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•

Select the folder, and press Alt-down arrow

•

Choose an item from the Places menu on the top panel. Your Home Folder and folders you have bookmarked are
listed here. For more on bookmarks, see the section called “Using Bookmarks For Your Favorite Locations”.

To close the current folder while opening the new one, hold down Shift when double-clicking, or press
Shift-Alt-down arrow.
Figure 6.3, “Contents of a folder in a spatial mode.” shows a spatial mode window that displays the contents of the
Computer folder.

Figure 6.3. Contents of a folder in a spatial mode.

In spatial mode each open Nautilus windows shows only one location. Selecting a second location will open a
second Nautilus window. Because each location remembers the previous position on screen in which it was opened
it allows you to easily recognize folders when many of them are open at once.
Some people consider spatial mode better, particularly for moving files or folders to different location, others find
the number of open windows daunting. Figure 6.4, “Three Folders Opened in Spatial Mode.” shows an example of
spatial browsing with many open locations.
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Figure 6.4. Three Folders Opened in Spatial Mode.

Because spatial mode will fill your screen with Nautilus windows it is important to be able to reposition them effectively. By holding the the ALT and clicking anywhere within the bounds of a Nautilus
window you may reposition it simply, instead of the requiring that you reposition it by dragging its title
bar.

Spatial Window Components
Table 6.1, “The Spatial Window Components” describes the components of file object windows.

Table 6.1. The Spatial Window Components
Component

Description

Menubar

Contains menus that you use to perform tasks in the file manager.
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Description
You can also open a popup menu from file manager windows. To open this
popup menu right-click in a file manager window. The items in this menu depend
on where you right-click. For example, when you right-click on a file or folder,
you can choose items related to the file or folder. When you right-click on the
background of a view pane, you can choose items related to the display of items
in the view pane.

View pane

Shows the contents of the following:
•

Folders

•

FTP sites

•

Windows shares

•

WebDAV servers

•

Locations that correspond to special URIs

Statusbar

Displays status information.

Parent folder selector

This drop-down list shows the hierarchy of the folder. Choose a folder from the
list to open it.
Hold down Shift while choosing from the list to close the current
folder as you open the new one.

Displaying Your Home Folder in a Spatial Window
To display your Home Folder, perform one of the following actions:
•

Double-click on the Home object on the desktop.

•

From a folder window's menubar, choose Places→Home.

•

From the top panel menubar, choose Places→Home Folder.

The spatial window displays the contents of your Home Folder.

Displaying a Parent Folder
A parent folder is the folder that contains the current folder. To display the contents of your current folder's parent,
do one of the following:
•

Choose File→Open Parent.

•

Press Alt-up arrow.

•

Choose from the parent folder selector at the bottom left of the window.

To close the current folder while opening the parent, hold down Shift while choosing from the parent folder selector, or press Shift-Alt-up arrow.
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Closing Folders
To close folders you may simply click on the close window button, this however may not be the most efficient way
to close many windows. If you would like to view only the current folder, and not the folders you opened to reach
the current folder, choose File→Close Parent Folders. If want to close all folders on the screen, choose File→Close
All Folders.

Displaying a Folder in a Browser Window
If you wish to display a single folder in browser mode, while otherwise continuing to work in spatial mode, perform
the following steps:
1.

Select a folder in while in spatial mode.

2.

Choose File→Browse Folder.

Opening a Location
You can open a folder or other location in spatial mode by typing its name.
Choose File→Open Location (L), and type the path or URI of the location you wish to open.

Browser Mode
The following section describes how to browse your system using the Nautilus file manager when configured in
browser mode. In browser mode, opening a folder updates the current file manager to show the contents of the new
folder.
For a comparison of browser mode and spatial mode, see the section called “File Manager Presentation”.

The File Browser Window
You can access the file browser in the following ways:
•

Choose Applications→System Tools→File Browser.

•

While in spatial mode you may open a folder in browser mode by right clicking on that folder and selecting
Browse Folder. A new file browser window will then open and display the contents of the selected folder in the
view pane.

•

If nautilus is set to always open browser windows, double clicking any folder will open a browser window, see
the section called “Behavior Preferences”.
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Figure 6.5. Contents of a Folder in a File Browser Window

In other distributions of the GNOME Desktop, the Home toolbar button might have another designation, for example, Documents.

The File Browser Window Components
Table 6.2, “File Browser Window Components” describes the components of a file browser window.

Table 6.2. File Browser Window Components
Component

Description

Menubar

Contains menus that you use to perform tasks in the file manager.
You can also open a popup menu from file manager windows. To open this
popup menu right-click in a file manager window. The items in this menu depend
on where you right-click. For example, when you right-click on a file or folder,
you can choose items related to the file or folder. When you right-click on the
background of a view pane, you can choose items related to the display of items
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Description
in the view pane.

Toolbar

Location bar

Side pane

Contains buttons that you use to perform tasks in the file manager.
•

Back Returns to the previously visited location. The adjacent drop down list
also contains a list of the most recently visited locations to allow you to return
to them faster.

•

Forward Performs the opposite function to the Back toolbar item. If you have
previously navigated back in time then this button returns you to the present.

•

Up Moves up one level to the parent of the current folder.

•

Reload Refreshes the contents of the current folder.

•

Home Opens your Home Folder.

•

Computer Opens your Computer folder.

•

Search Opens the search bar.

The location bar is a very powerful tool for navigating your computer. It can appear in three different ways depending on your selection. For more on using the
location bar see the section called “Using the Location Bar”. In all three configurations the location bar always contains the following items.
•

Zoom buttons: Enable you to change the size of items in the view pane.

•

View as drop-down list: Enables you to choose how to show items in your
view pane.

Performs the following functions:
•

Shows information about the current file or folder.

•

Enables you to navigate through your files.

To display the side pane, choose View→Side Pane. The side pane contains a
drop-down list that enables you to choose what to show in the side pane. You can
choose from the following options:
•

Places
Displays places of particular interest.

•

Information
Displays the icon and information about the current folder. Buttons may appear in the side pane, these buttons enable you to perform actions on the current folder, other than the default action.

•

Tree
Displays a hierarchical representation of your file system. You can use the
Tree to navigate through your files.

•

History
Contains a history list of files, folders, FTP sites, and URIs that you have recently visited.

•

Notes
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Enables you to add notes to your files and folders.
•

Emblems
Contains emblems that you can add to a file or folder.

To close the side pane, click on the X button at the top right of the side pane.
View pane

Statusbar

Shows the contents of the following:
•

Folders

•

FTP sites

•

Windows shares

•

WebDAV servers

•

Locations that correspond to special URIs

Displays status information.

Showing and Hiding File Browser Window Components
To show or hide any of the components of the file browser described in Table 6.2, “File Browser Window Components” select any of the following items from the menu:
•

To hide the side pane, choose View→Side Pane. To display the side pane again, choose View→Side Pane again.
Alternatively you may press F9 to toggle the visibility of the side pane.

•

To hide the toolbar, choose View→Main Toolbar. To display the toolbar again, choose View→Main Toolbar
again.

•

To hide the location bar, choose View→Location Bar. To display the location bar again, choose View→Location Bar again.

•

To hide the statusbar, choose View→Statusbar. To display the statusbar again, choose View→Statusbar again.

Using the Location Bar
Depending on your selection, the location bar can show either a location field, a button bar, or a search field. Each is
useful in different situations and as you become experienced working with the Nautilus file manager you will become proficient at switching between them.
•

Location field
By pressing Ctrl-L or Leading Slash (/) or choosing Go→Location the Location : field will appear and allow
you to type the location you wish to browse to manually. To make the location field disappear hit the Esc key.
The location field is particularly useful for jumping to a known folder very quickly.

Figure 6.6. The location bar.

•

Button bar
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By default the button bar is shown. Each button represents a folder, by clicking on them you can change your
location. You can also drag buttons, for example to another location, in order to copy a folder. The button bar is
excellent for jumping quickly between frequently accessed folders.

Figure 6.7. The button bar.

•

Search bar
By pressing Ctrl-F or selecting the Search toolbar button the search bar appears. For more information on
searching see the section called “Searching For Files”. The search bar is excellent for locating files of folders
when you are not sure of their exact location.

Figure 6.8. The button bar.

If you prefer the location field over the button bar you can choose for this to be shown by default. See the section
called “Behavior Preferences” for instructions on how to do this.

Displaying Your Home Folder
To quickly display your Home Folder, perform one of the following actions from a file browser window:
•

Choose Go→Home.

•

Click on the Home toolbar button.

•

Click on the Home button in the Places side pane.

The file browser window displays the contents of your Home Folder.

Displaying a Folder
The contents of a folder can be displayed in either list or icon view by selecting the appropriate item in the location
bar View as menu. For more information on the list and icon view see the section called “Using Views to Display
Your Files and Folders”
•

Double-click on the folder in the view pane.

•

Use the Tree in the side pane. For more information, see the section called “Using the Tree From the Side Pane”.

•

Click on the Location buttons in the location bar.

•

Press Ctrl-L to show the text Location field, type the path of the folder that you want to display, then press Return. The Location field includes an autocomplete feature. As you type a path, the file manager reads your file
system. When you type enough characters to uniquely identify a directory, the file manager completes the name
of the directory in the Location field.

•

Use the Back toolbar button and the Forward toolbar button to browse through your navigation history.

To change to the folder that is one level above the current folder, choose Go→Up. Alternatively, click on the Up
toolbar button.
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Displaying a Parent Folder
The parent folder of the current folder which you are browsing is the one which exists, in a hierarchical representation, one level above the current. To display the contents of parent folder, perform one of the following steps:
•

Press the Up button on the toolbar.

•

Choose Go→Open Parent from the menubar.

•

Press the Backspace key.

Using the Tree From the Side Pane
The Tree view is one of the most useful features of the side pane. It displays a hierarchical representation of your
file system and provides a convenient way to browse and to navigate your file system. To display the Tree in the
side pane, choose Tree from the drop-down list at the top of the side pane.
In the Treeview, open folders are represented as downwards facing arrows.
Table 6.3, “Tree Tasks” describes tasks you can perform with the Tree, and how to do so.

Table 6.3. Tree Tasks
Task

Action

Open the Tree.

Choose Tree from the drop-down list at the top of the
side pane.

Close the Tree.

Choose another item from the drop-down list at the top of
the side pane.

Expand a folder in the Tree.

Click on the arrow next to the folder in the Tree.

Collapse a folder in the Tree.

Click on the arrow next to the folder in the Tree.

Display the contents of a folder in the view pane.

Select the folder in the Tree.

Open a file.

Select the file in the Tree.

You can set your preferences so that the Tree does not display files. For more information, see the section called
“Views Preferences”.

Using Your Navigation History
The file browser window maintains a history list of files, folders, FTP sites, and URI locations you have recently
visited. You can use the history list to navigate to quickly return to these places. Your history list contains the last
ten items that you viewed.
To clear your history list choose Go→Clear History.

Navigating Your History List Using the Go Menu
To display a list of previously-viewed items, choose the Go menu. Your history list is displayed in the lower part of
the Go menu. To open an item in your history list, simply click on the item.
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Navigating Your History List Using the Toolbar
To use the toolbar to navigate your history list, perform one of the following actions:
•

To open the folder or URI in your history list, click on the Back toolbar button.

•

To open the folder or URI in your history list, click on the Forward toolbar button.

•

To display a list of previously-viewed items, click on the down arrow to the right of the Back toolbar button. To
open an item from this list, click on the item.

•

To display a list of items that you viewed after you viewed the current item, click on the down arrow to the right
of the Forward toolbar button. To open an item from this list, click on the item.

Navigating Your History List Using History in the Side Pane
To display the History list in the side pane, choose History from the drop-down list at the top of the side pane. The
History list in the side pane displays a list of your previously-viewed items.
To display an item from your history list in the view pane, double-click on the item in the History list.

Opening Files
When you open a file, the file manager performs the default action for that file type.
For example, opening a music file will play it with the default music playing application, opening a text file will allow you to read and edit it in a text editor, and opening an image file will display the image.
The file manager checks the contents of a file to determine the type of a file. If the first lines do not determine the
type of the file, then the file manager checks the file extension.
If you open an executable text file, that is, one that Nautilus considers can be run as a program, then
you will be asked what you want to do: run it, or display it in a text editor. You can modify this behaviour in the File Management preferences.

Executing the Default Action
To execute the default action for a file, double-click on the file. For example, the default action for plain text documents is to display the file in a text viewer. In this case, you can double-click on the file to display the file in a text
viewer.
You can set your file manager preferences so that you click once on a file to execute the default action. For more information, see the section called “Behavior Preferences”.

Executing Non-Default Actions
To execute actions other than the default action for a file, select the file that you want to perform an action on. In the
File menu you will either have "Open with" choices, or an Open With submenu. Select the desired option from this
list.
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Adding Actions
To add actions associated with a file type, perform the following steps:
1.

In the view pane, select a file of the type to which you want to add an action.

2.

Choose File→Open with Other Application.

3.

Either choose an application in the open with dialog or browse to the program with which you wish to open this
type.

The action you have chosen is now added to the list of actions for that particular file type. If there was no prior action associated with the type, the newly added action is the default.
You may also add actions in the Open With tabbed section under File→Properties.

Modifying Actions
To modify the actions associated with a file or file type, perform the following steps:
1.

In the view pane, select a file of the type to which you want to modify the action.

2.

Choose File→Properties.

3.

Choose Open With tabbed section.

4.

Use Add or Remove buttons to tailor the list of actions. Select the default action with the option to the left of
the list.

Searching For Files
The Nautilus file manager includes an easy and simple to use way search for your files and folders. To begin a
search press Ctrl-F or select the Search toolbar button. The search bar should appear as in Figure 6.9, “The search
bar.”

Figure 6.9. The search bar.

Enter characters present in the name or contents of the file or folder you wish to find and press Enter. The results of
your search should appear in the view pane as illustrated in Figure 6.10, “The result of a search.”
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Figure 6.10. The result of a search.

If you are not happy with your search you can refine it by adding addition conditions. This allows you to restrict the
search to a specific file type or location. To add search conditions click the + icon. Figure 6.11, “Restricting a
search.” shows a search which has been restricted to the users home directory and to only search for text files.
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Figure 6.11. Restricting a search.

Saving Searches
Nautilus searches can also be saved for future use. Once saved, searches may be reopened later. Figure 6.12,
“Browsing the results of a saved search.” shows a user with three saved searches, browsing one of them.

Figure 6.12. Browsing the results of a saved search.
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Saved searches behave exactly like regular folders, for example you can open, move or delete files from within a
saved search.

Managing Your Files and Folders
This section describes how to work with your files and folders.

Using Views to Display Your Files and Folders
The file manager includes views that enable you to show the contents of your folders in different ways, icon view,
and list view.
•

Icon view
Figure 6.13, “The Home Folder displayed in a icon view.” Shows the items in the folder as icons.

Figure 6.13. The Home Folder displayed in a icon view.

•

List view
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Figure 6.14, “The Home Folder displayed in a list view.” Shows the items in the folder as a list.

Figure 6.14. The Home Folder displayed in a list view.

You may use the View menu, or the View as drop-down list to choose between icon or list view. You can specify
how you want to arrange or sort items in the folder and modify the size of the items in the view pane. The following
sections describe how to work with icon view and list view.

To Arrange Your Files in Icon View
When you display the contents of a folder in icon view, you can specify how to arrange the items in the folder. To
specify how to arrange items in icon view, choose View→Arrange Items. The Arrange Items submenu contains the
following sections:
•

At the top is an option that enables you to arrange your files manually.

•

The middle section contains options that enable you to sort your files automatically.

•

The bottom section contains options that enable you to modify how your files are arranged.

Choose the appropriate options from the submenu, as described in the following table:
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Option

Description

Manually

Select this option to arrange the items manually. To arrange the items manually,
drag the items to the location you require within the view pane.

By Name

Select this option to sort the items alphabetically by name. The order of the items
is not case sensitive. If the file manager is set to display hidden files, the hidden
files are shown last.

By Size

Select this option to sort the items by size, with the largest item first. When you
sort items by size, the folders are sorted by the number of items in the folder. The
folders are not sorted by the total size of the items in the folder.

By Type

Select this option to sort the items alphabetically by object type. The items are sorted alphabetically by the description of their MIME type. The MIME type identifies the format of a file, and enables applications to read the file. For example, an
email application can use the image/png MIME type to detect that a PNG file is
attached to an email.

By Modification Date

Select this option to sort the items by the date the items were last modified. The
most recently modified item is first.

By Emblems

Select this option to sort the items by any emblems that are added to the items.
The items are sorted alphabetically by emblem name. Items that do not have emblems are last.

Compact Layout

Select this option to arrange the items so that the items are closer to each other.

Reversed Order

Select this option to reverse the order of the option by which you sort the items.
For example, if you sort the items by name, select the Reversed Order option to
sort the items in reverse alphabetical order.

To Arrange Your Files in List View
When you display the contents of a folder in list view, you can specify how to arrange the items in the folder. To
specify how to arrange items in list view, click on the header of the column specifying the property by which you
wish to arrange the items. To inverse the sorting order click on the same column header again.
To add or remove columns from the list view choose View→Visible Columns
The file manager remembers how you arrange the items in a particular folder. The next time that you display the
folder, the items are arranged in the way that you selected. In other words, when you specify how to arrange the
items in a folder, you customize the folder to display the items in that way. To return the arrangement settings of the
folder to the default arrangement settings specified in your preferences, choose View→Reset View to Defaults.

To Change the Size of Items in a View
You can change the size of items in a view. You can change the size if the view displays a file or a folder. You can
change the size of items in a view in the following ways:
•

To enlarge the size of items in a view, choose View→Zoom In.

•

To reduce the size of items in a view, choose View→Zoom Out.

•

To return items in a view to the normal size, choose View→Normal Size.
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You can also use the zoom buttons on the location bar in a browser window to change the size of items in a view.
Table 6.4, “Zoom Buttons” describes how to use the zoom buttons.

Table 6.4. Zoom Buttons
Button

Button Name

Description

Zoom Out button

Click on this button to reduce the size of items in a
view.

Normal Size button

Click on this button to return items in a view to
normal size.

Zoom In button

Click on this button to enlarge the size of items in a
view.

The file manager remembers the size of items in a particular folder. The next time that you display the folder, the
items are displayed in the size that you selected. In other words, when you change the size of items in a folder, you
customize the folder to display the items at that size. To return the size of the items to the default size specified in
your preferences, choose View→Reset View to Defaults.

Selecting Files and Folders
You can select files and folders in several ways in the file manager. Typically this is achieved by clicking on the
files using the mouse, as explained in Table 6.5, “Selecting Items in the File Manager”. In addition the section called
“Selecting Files Matching a Specific Pattern” describes how to select a group of files matching a specific pattern.

Table 6.5. Selecting Items in the File Manager
Task

Action

Select an item

Click on the item.

Select a group of contiguous items

In icon view, drag around the files that you want to select.
In list view, click on the first item in the group. Press-and-hold Shift,
then click on the last item in the group.

Select multiple items

Press-and-hold Ctrl. Click on the items that you want to select.
Alternatively, press-and-hold Ctrl, then drag around the files that you
want to select.

Select all items in a folder

Choose Edit→Select All Files.

To perform the default action on an item, double-click on the item. You can set your file manager preferences so
that you click once on a file to execute the default action. For more information, see the section called “Behavior
Preferences”.
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Selecting Files Matching a Specific Pattern
Nautilus allows you to select all files matching a pattern based upon their filename and an optional number of wildcards. This can be useful if, for example, you wish to select all files which contain the phrase "memo" in their filename. Table 6.6, “Selecting Items in the File Manager” gives some examples of possible patterns and the resulting
files they would match.

Table 6.6. Selecting Items in the File Manager
Pattern

Files Matched

note.*

This pattern would match files called note, with any extension.

*.ogg

This pattern would match all files with the .ogg extension

*memo*

This pattern would match all files or folders whose name contains the
word memo.

To perform the Select Pattern command Choose Edit→Select Patterns from the menu. After entering the desired pattern you are left with those files or folders which matched the pattern selected. You may then do with the selected
files or folders what you choose.

Drag-and-Drop in the File Manager
You can use drag-and-drop to perform several tasks in the file manager. When you drag-and-drop, the mouse pointer
provides feedback about the task that you perform. Table 6.7, “Drag-and-Drop in the File Manager” describes the
tasks that you can perform with drag-and-drop. The table also shows the mouse pointers that appear when you dragand-drop.

Table 6.7. Drag-and-Drop in the File Manager
Task

Action

Mouse Pointer

Move an item

Drag the item to the new location.

Copy an item

Grab the item, then press-and-hold Ctrl. Drag the item to the location
where you want the copy to reside.

Create a symbolic link to Grab the item, then press-and-hold Ctrl-Shift. Drag the item to the
an item
location where you want the symbolic link to reside.
Ask what to do with the Grab the item, then press-and-hold Alt. You may also use the middle
item you drag
mouse button to perform the same operation. Drag the item to the
location where you want the item to reside. Release the mouse button. A popup menu appears. Choose one of the following items from
the popup menu:
•

Move here
Moves the item to the location.

•

Copy here
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Action

Mouse Pointer

Copies the item to the location.
•

Link here
Creates a symbolic link to the item at the location.

•

Set as Background
If the item is an image, sets the image to be the background. You
can use this command to set the background of the desktop, the
side pane or the view pane.

•

Cancel
Cancels the drag-and-drop operation.

Moving a File or Folder
You can move a file or folder by dragging it with the mouse, or with the cut and paste commands. The following
sections describe these two methods.

Drag to the New Location
To drag a file or folder to a new location, perform the following steps:
1.

2.

Open two file manager windows:
•

The window containing the item you want to move.

•

The window you want to move it to, or the window containing the folder you want to move it to.

Drag the file or folder that you want to move to the new location. If the new location is a window, drop it anywhere in the window. If the new location is a folder icon, drop the item you are dragging on the folder.

To move the file or folder to a folder that is one level below the current location, do not open a new window. Instead, drag the file or folder to the new location in the same window.
For more on dragging items, see the section called “Drag-and-Drop in the File Manager”.

Cut and Paste to the New Location
You can cut a file or folder and paste the file or folder into another folder, as follows:
1.

Select the file or folder that you want to move, then choose Edit→Cut File.

2.

Open the folder to which you want to move the file or folder, then choose Edit→Paste Files.

Copying a File or Folder
You can copy a file or folder by dragging it with the mouse, or with the copy and paste commands. The following
sections describe these two methods.

Drag to the New Location
To copy a file or folder, perform the following steps:
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Open two file manager windows:
•

The window containing the item you want to move.

•

The window you want to move it to, or the window containing the folder you want to move it to.

Drag the file or folder that you want to move to the new location. Press-and-hold Ctrl either before or during
the drag. If the new location is a window, drop it anywhere in the window. If the new location is a folder icon,
drop the item you are dragging on the folder.

To copy the file or folder to a folder that is one level below the current location, do not open a new window. Instead,
grab the file or folder, then press-and-hold Ctrl. Drag the file or folder to the new location in the same window.
For more on dragging items, see the section called “Drag-and-Drop in the File Manager”.

Copy and Paste to the New Location
You can copy a file or folder and paste the file or folder into another folder, as follows:
1.

Select the file or folder that you want to copy, then choose Edit→Copy File.

2.

Open the folder to which you want to copy the file or folder, then choose Edit→Paste Files.

Duplicating a File or Folder
To create a copy of a file or folder in the current folder, perform the following steps:
1.

Select the file or folder that you want to duplicate.

2.

Choose Edit→Duplicate. Alternatively, right-click on the file or folder, then choose Duplicate.
A copy of the file or folder appears in the current folder.

Creating a Folder
To create a folder, perform the following steps:
1.

Select the folder where you want to create the new folder.

2.

Choose File→Create Folder. Alternatively, right-click on the background of the window, then choose Create
Folder.
An untitled folder is added to the location. The name of the folder is selected.

3.

Type a name for the folder, then press Return.

Templates and Documents
You can create templates from documents that you frequently create. For example, if you often create invoices, you
can create an empty invoice document and save the document as invoice.doc in the $HOME/Templates
folder.
You can also access the templates folder from a file browser window. Choose Go→Templates.
The template name is displayed as a submenu item in the Create Document menu.
You can also create subfolders in the template folder. Subfolders display as submenus in the menu.
You can also share templates. Create a symbolic link from the template folder to the folder containing the shared
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templates.

To Create a Document
If you have document templates, you can choose to create a document from one of the installed templates.
To create a document perform the following steps:
1.

Select the folder where you want to create the new document.

2.

Choose File→Create Document. Alternatively, right-click on the background of the view pane, then choose
Create Document.
The names of any available templates are displayed as submenu items from the Create Document menu.

3.

Double-click on the template name for the document that you want to create.

4.

Rename the document before saving to the appropriate folder.

Renaming a File or Folder
To rename a file or folder perform the following steps:
1.

Select the file or folder that you want to rename.

2.

Choose Edit→Rename. Alternatively, right-click on the file or folder, then choose Rename.
The name of the file or folder is selected.

3.

Type a new name for the file or folder, then press Return.

Moving a File or Folder to Trash
To move a file or folder to Trash perform the following steps:
1.

Select the file or folder that you want to move to Trash.

2.

Choose Edit→Move to Trash. Alternatively, right-click on the file or folder, then choose Move to Trash.

Alternatively, you can drag the file or folder to the Trash object on the desktop.
When you move a file or folder from a removable media to Trash, the file or folder is stored in a Trash
location on the removable media. To remove the file or folder permanently from the removable media,
you must empty Trash.

Deleting a File or Folder
When you delete a file or folder, the file or folder is not moved to Trash, but is deleted from your file system immediately. The Delete menu item is only available if you select the Include a Delete command that bypasses Trash option in the File Management Preferences dialog.
To delete a file or folder perform the following steps:
1.

Select the file or folder that you want to delete.

2.

Choose Edit→Delete. Alternatively, right-click on the file or folder, then choose Delete.
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Creating a Symbolic Link to a File or Folder
A symbolic link is a special type of file that points to another file or folder. When you perform an action on a symbolic link, the action is performed on the file or folder to which the symbolic link points. However, when you delete
a symbolic link, you delete the link file, not the file to which the symbolic link points.
To create a symbolic link to a file or folder, select the file or folder to which you want to create a link. Choose
Edit→Make Link. A link to the file or folder is added to the current folder.
Alternatively, grab the item to which you want to create a link, then press-and-hold Ctrl-Shift. Drag the item to the
location where you want to place the link.
By default, the file manager adds an emblem to symbolic links.
The permissions of a symbolic link are determined by the file or folder to which a symbolic link
points.

For more on dragging items, see the section called “Drag-and-Drop in the File Manager”.

Viewing the Properties of a File or Folder
To view the properties of a file or folder, perform the following steps:
1.

Select the file or folder whose properties you want to view.

2.

Choose File→Properties. A properties dialog is displayed.

3.

Use the properties dialog to view the properties of the file or folder.

4.

Click Close to close the properties dialog.

The following table lists the properties that you can view or set for files and folders, the exact information shown depends on the object type:
Property

Description

Name

The name of the file or folder. You can change the name here and the file or folder
will be renamed when you click on Close.

Type

The type of object, file or folder for example.

Location

The system path for the object. This represents where the object is situated on your
computer, relative to the system root.

Volume

The volume on which a folder resides. This is the physical location of the folder, on
which media it resides, for example which hard disk or CDROM drive.

Free space

The amount of free space on the media upon which a folder resides. This represents
the maximum amount of data you can copy to this folder.

MIME Type

The official naming of the type of file.

Modified

The date and time at which the object was last changed.
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Property

Description

Accessed

The date and time at which the object was last viewed.

Changing Permissions
Permissions are settings assigned to each file and folder that determine what type of access users can have to the file
or folder. The following table lists the permissions that you can set for files and folders, and the effect of the permission on files and folders:
Permission

File

Folder

Read

Permission to read the file.

Permission to list the contents of the folder.

Write

Permission to make changes to the file.

Permission to create and delete files in the
folder.

Execute

Permission to run the file as a program. This is Permission to access files in the directory.
only relevant if the file is a program or script.

You can set permissions for different types of user. The following table lists the types of user for which you can set
permissions:
User Category

Description

Owner

The user that created the file or folder.

Group

The group to which the owner belongs.

Others

All other users who are not in the group to which the owner belongs.

To change the permissions on a file or folder perform the following steps:
1.

Select the file or folder that you want to change.

2.

Choose File→Properties. A properties dialog is displayed.

3.

Click on the Permissions tab. In the Permissions tabbed section, use the drop-down lists and check boxes to
change the permissions for the file or folder. The following table describes the dialog elements on the Permissions tabbed section:

Element

Description

File owner

To change the owner of the file or folder, select the owner from the
drop-down list.

File group

To change the group to which a file or folder belongs, select the group
from the drop-down list.

Owner

Select the permissions that you want to apply to the owner of the file or
folder.
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Element

Description

Group

Select the permissions that you want to apply to the group to which the
owner of the file or folder belongs.

Others

Select the permissions that you want to apply to all other users who are
not in the group to which the owner belongs.

Text view

Displays the permissions that you select from the Read, Write, and Execute options, in text format.

Number view

Displays the permissions that you select from the Read, Write, and Execute options, in text format.

Last changed

Displays the date and time that the file or folder was last modified.

4.

Click Close to close the properties dialog.

Adding Notes to Files and Folders
You can add notes to files or folders. You can add notes to files or folders in the following ways:
•

From the properties dialog

•

From Notes in the side pane

To Add a Note Using the Properties Dialog
To add a note to a file or folder, perform the following steps:
1.

Select the file or folder to which you want to add a note.

2.

Choose File→Properties. A properties dialog is displayed.

3.

Click on the Notes tab. In the Notes tabbed section, type the note.

4.

Click Close to close the properties dialog. A note emblem is added to the file or folder.

To delete a note, delete the note text from the Notes tabbed section.

To Add a Note Using Notes in the Side Pane
To add a note to a file or folder, perform the following steps:
1.

Open the file or folder to which you want to add a note in the view pane.

2.

Choose Notes from the drop-down list at the top of the side pane. To display the side pane, choose View→Side
Pane.

3.

Type the note in the side pane. A note emblem is added to the file or folder in the view pane, and a note icon is
added to the side pane. You can click on this icon to display the note.

To delete a note, delete the note text from Notes in the side pane.
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Using Bookmarks For Your Favorite Locations
You can keep a list of bookmarks in Nautilus: folders and other locations that you frequently need to open.
Your bookmarks are listed in the following places:
•

The Places menu on the top panel.

•

The Places menu in a folder window.

•

The Bookmarks menu in a Nautilus browser window.

•

The side pane in the Open File dialog. This allows you to quickly open a file that is in one of your bookmarked
locations.

•

The list of commonly used locations in the Save File dialog. This allows you to quickly save a file to a location
you have in your bookmarks.

To open an item that is in your bookmarks, choose the item from a menu.

Adding a Bookmark
To add a bookmark, open the folder or location that you want to bookmark, then choose Places→Add Bookmark.
If you are using a Nautilus browser window, choose Bookmarks→Add Bookmark.

To Edit a Bookmark
To edit your bookmarks perform the following steps:
1.

Choose Places→Edit Bookmarks, or in a browser window, Bookmarks→Edit Bookmarks. An Edit Bookmarks
dialog is displayed.

2.

Select the bookmark on the left side of the Edit Bookmarks dialog. Edit the details for the bookmark on the
right side of the Edit Bookmarks dialog, as follows:

Dialog Element

Description

Name

Use this text box to specify the name that identifies the bookmark in the menus.

Location

Use this field to specify the location of the bookmark.
Folders on your system use the file:/// URI.

3.

To delete a bookmark, select the bookmark on the left side of the dialog. Click Delete.

Using Trash

Trash is a special folder that holds files that you no longer want to keep. Files in the Trash are not deleted permanently until you empty the trash. This two-stage process is in case you change your mind, or accidentally remove the
wrong file.
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You can move the following items to Trash:
•

Files

•

Folders

•

Desktop objects

If you need to retrieve a file from Trash, you can display Trash and move the file out of Trash. When you empty
Trash, you delete the contents of Trash permanently.

To Display Trash
You can display the contents of Trash in the following ways:
•

From a file browser window
Choose Go→Trash. The contents of Trash are displayed in the window.

•

From a spatial window
Choose Places→Trash. The contents of Trash are displayed in the window.

•

From the desktop
Double-click on the Trash object on the desktop.

To Empty Trash
You can empty the contents of Trash in the following ways:
•

From a file browser window
Choose File→Empty Trash.

•

From the desktop
Right-click on the Trash object, then choose Empty Trash.
When you empty trash, you destroy all files in the trash. Be sure that the trash only contains files you
no longer need.

Hidden Files
By default, Nautilus does not display certain system and backup files in folders. This prevents accidental modification or deletion of them, which can impair the operation of your computer, and also reduces clutter in locations such
as your Home Folder. Nautilus does not display:
•

Hidden files, whose filename begins with a period (.),

•

Backup files, whose filename ends with a tilde (~)

•

Files that are listed in a particular folder's .hidden file.

You may hide or show hidden files in a particular folder by selecting View→Show Hidden Files.
To set Nautilus to always show hidden files, see the section called “Nautilus Preferences”.

Hiding a File or Folder
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To hide a file or folder in Nautilus, either rename the file so its name begins with the period (.) character, or create a
text file named .hidden in the same folder, and add its name to it, as in the example below:
filename
foldername
You may need to refresh the relevant Nautilus window to see the change: press Ctrl-R.

Modifying the Appearance of Files and Folders
The Nautilus file manager enables you to modify the appearance of your files and folders in several ways. You may
customize the way files or folders look by attaching emblems or backgrounds to them. You can also change format
in which Nautilus displays these items to you. The following sections describe how to do so.

Icons and Emblems
The file manager displays your files and folders as icons. Depending on the type of the file the icon may be a image
representative of the file type, a small thumbnail or preview showing the files contents. You can also add emblems
to your file and folder icons. Such emblems appear in addition to the file icon and provide another means to manage
your files. For example you can mark a file as important by adding an Important emblem to it, creating the following
visual effect:

Notice how the file on the left is distinguished from the file on the right by the addition of the Important (!) icon. See
the section called “Adding an Emblem to a File or Folder” for more on adding emblems.
The file manager automatically applies emblems for the following types of files:
•

Symbolic links

•

Items for which you have the following permissions:
•

No read permission

•

No write permission

The following table shows the default emblems:
Default Emblem

Description
Symbolic link
No write permission
No read permission
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Description

Adding an Emblem to a File or Folder
To add an emblem to an item perform the following steps:
1.

Select the item to which you want to add an emblem.

2.

Right-click on the item, then choose Properties. A properties dialog is displayed.

3.

Click on the Emblems tab to display the Emblems tabbed section.

4.

Select the emblem to add to the item.

5.

Click Close to close the properties dialog.

In browser windows you may also add emblems to items by dragging them from the emblem side pane.

Creating a New Emblem
To Create a new emblem, perform the following steps:
1.

Choose Edit→Backgrounds and Emblems.

2.

Click on the Emblem button, then click on the Add a New Emblem button. A Create a New Emblem dialog is
displayed.

3.

Type a name for the emblem in the Keyword text box.

4.

Click on the Image button. A dialog is displayed, click Browse. When you choose an emblem, click OK.

5.

Click OK on the Create a New Emblem dialog.

Changing the Icon for a File or Folder
To change the icon that represents an individual file or folder, perform the following steps:
1.

Select the file or folder that you want to change.

2.

Choose File→Properties. A properties dialog is displayed.

3.

On the Basic tabbed section, click on the current Icon. A Select custom icon dialog is displayed.

4.

Use the Select custom icon dialog to choose the icon to represent the file or folder.

5.

Click Close to close the properties dialog.

To restore an icon from a custom icon to the default icon, Select the file or folder that you want to change, choose
File→Properties. click on the Icon button, in the Select custom icon dialog click Revert.

Changing Backgrounds
The file manager includes backgrounds that you can use to change the look-and-feel of the following screen components:
•

Desktop

•

Side pane and view pane of a file browser window
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•

Spatial mode windows

•

Panels

Using Removable Media

To change the background of a screen component perform the following steps:
1.

Choose Edit→Backgrounds and Emblems. The Backgrounds and Emblems dialog is displayed.

2.

To display a list of patterns that you can use on the background, click on the Patterns button. To display a list of
the colors that you can use on the background, click on the Colors button.

3.

To change the background to a pattern, drag the pattern to the screen component. To change the background to
a color, drag the color to the screen component.

4.

Click Close to close the dialog.

To reset the background of the view pane or side pane to the default background, right-click on the background of
the pane, then choose Use Default Background.

To Add a Pattern
To add a pattern to the patterns that you can use on your screen components, choose Edit→Backgrounds and Emblems. Click on the Patterns button, then click on the Add a New Pattern button. A dialog is displayed. Use the dialog to find the new pattern. Click OK to add the new pattern to the Backgrounds and Emblems dialog.

To Add a Color
To add a color to the colors that you can use on your screen components, choose Edit→Backgrounds and Emblems.
Click on the Colors button, then click on the Add a New Color button. A color selector dialog is displayed. Use the
color wheel or the sliders to choose the color. Click OK to add the new color to the Backgrounds and Emblems dialog.

Using Removable Media
The file manager supports all removable media that have the following characteristics:
•

The removable media has an entry in the /etc/fstab file. The /etc/fstab file describes the file systems
that the computer uses.

•

The user option is specified in the entry for the removable media in the /etc/fstab file.

To Mount Media
To mount media is to make the file system of the media available for access. When you mount media, the file system
of the media is attached as a subdirectory to your file system.
To mount media, insert the media in the appropriate device. An object that represents the media is added to the
desktop. The object is added only if your system is configured to mount the device automatically when media is detected.
If your system is not configured to mount the device automatically, you must mount the device manually. Doubleclick on the Computer icon from the desktop. A Computer dialog is displayed. Double-click on the object that represents the media. For example, to mount a floppy diskette, double-click on the Floppy object. An object that represents the media is added to the desktop.
You cannot change the name of a removable media object.
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To Display Media Contents
You can display media contents in any of the following ways:
•

Double-click on the object that represents the media on the desktop.

•

Right-click on the object that represents the media on the desktop, then choose Open.

A file manager window displays the contents of the media. To reload the display, click on the Reload button.

To Display Media Properties
To display the properties of removable media, right-click on the object that represents the media on the desktop,
then choose Properties. A dialog displays the properties of the media.
To close the properties dialog, click Close.

To Format a Floppy Disk
To format media is to prepare the media for use. You can use the file manager to format floppy disks.

Warning
When you format, you destroy all files on your floppy disk. Do not format floppies containing files
you wish to keep.
To format a floppy disk, right-click on the object that represents the floppy on the desktop, then choose Format. A
Floppy Formatter dialog is displayed. See the Floppy Formatter documentation for more details.

To Eject Media
To eject media, right-click on the media object on the desktop, then choose Eject. If the drive for the media is a motorized drive, the media is ejected from the drive. If the drive for the media is not motorized, wait until the desktop
object for the media disappears, then eject the media manually.
You cannot eject media from a motorized drive when the media is mounted. To eject media, first unmount the media. To remove a floppy diskette from the drive, perform the following steps:
1.

Close all file manager windows, Terminal windows, and any other windows that access the diskette.

2.

Right-click on the object that represents the diskette on the desktop, then choose Eject. The desktop object for
the diskette disappears.

3.

Eject the diskette from the drive.
You must unmount removable media before ejecting. Do not eject a diskette from the drive before you
unmount the diskette. Do not remove a USB flash drive before you unmount the flash drive. If you do
not unmount the media first you might lose data.
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Writing CDs or DVDs
Writing a CD or DVD is a good method of backup up your important documents. To do this, your computer must
have a CD or DVD writer.
A simple way to check what sort of CD or DVD drive your computer has is to choose Places→Computer from the top panel menubar. If the icon for your CD drive has terms like "CD-RW" or
"DVD(+-)R" in its label, then your computer is able to write discs.
You can start choosing files to burn to a disc at any time. The file manager provides a special folder for files and
folders that you want to write to a CD or DVD. From here you can write the contents of the location to a CD or
DVD easily.

Creating Data Discs
To write a CD or DVD, perform the following steps:
1.

In a folder window menubar, choose Places→CD/DVD Creator. The file manager opens the CD/DVD Creator
folder.
In a File Browser window, this item is in the Go menu.

2.

Drag the files and folders that you want to write to CD or DVD to the CD/DVD Creator folder.

3.

Insert a writable CD or DVD into the CD/DVD writer device on your system.

4.

Press the Write to Disc button, or choose File→Write to CD/DVD. A Write to Disc dialog is displayed.

5.

Use the Write to Disc dialog to specify how you want to write the CD, as follows:

Dialog Element

Description

Write disc to

Select the device to which you want to write the CD from
the drop-down list. To create an CD image file, select the
File image option. A CD image file is a normal file that
contains all of the data in the same format as a CD, that
you can write to a CD later.

Disc name

Type a name for the CD in the text box.

Data size

Shows the size of the data to be written to disc. The blank
disk must be at least this size.

Write speed

Select the speed at which you want to write the CD from
the drop-down list.

6.

Click on the Write button.
If you selected the File image option from the Target to write to drop-down list, a Choose a filename for the
disc image dialog is displayed. Use the dialog to specify the location where you want to save the disc image
file. By default, disc image files have a .iso file extension.
A Writing disc dialog is displayed. This process takes some time. When the disc is written or when the disc im77
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age file is created, a message to indicate that the process is complete is displayed in the dialog.
You can set the CD/DVD Creator folder to open automatically when you instert a blank disc. See Removable Drives and Media Preferences.

The filesystem written to the CD will be readable with long filenames on all recent operating systems.
Both the Joliet and the Rock Ridge CD-ROM filesystem extensions are used.

Copying CDs or DVDs
You can create a copy of a CD or DVD, either to another disc or to an image file stored on your computer. To create
a copy, perform the following steps:
1.

Insert the disc you want to copy.

2.

Choose Places→Computer from the top panel menubar.

3.

Right-click on the CD icon, and choose Copy Disc.

4.

The Write to Disc dialog is displayed.

If you have only one drive with write capabilities, the process will first create a disc image file on your computer. It
will then eject the original disk, and ask you to change it for a blank disk on which to write the copy.
If you want to create more than one copy, choose the Image File option on the Write to Disc and then
write the disc image: see the section called “Creating a Disc from an Image File”.

Creating a Disc from an Image File
You can write a disc image to a CD or DVD. For example, you may have downloaded a disc image from the internet, or previously created one yourself. Disc images usually have a .iso file extension and are sometimes called
iso files.
To write a disc image, right-click on the disc image file, then choose Write to Disc from the popup menu.

Navigating Remote Servers
The Nautilus file manager provides an integrated access point to your files, applications, FTP sites, Windows shares,
WebDav servers and SSH servers.

To Access a remote server
You can use the file manager to access a remote server, be it an FTP site, a Windows share, a WebDav server or an
SSH server.
To access a remote server, choose File→Connect to Server. You may also access this dialog from the menubar by
choosing Places→Connect to Server.
In the Connect to Server dialog, you may click on the Browse network button to close this dialog and view services
available on your network in a nautilus window.
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To connect to a remote server, start by choosing the service type, then enter the server address.
If required by your server, you may provide the following optional information :
Dialog Element

Description

Port

Port to connect to on the server. This should only be used if it is necessary to change
the default port, you would normally leave this blank.

Folder

Folder to open upon connecting to server.

User Name

The user name of the account used to connect to the server. This should be supplied
with the connexion information if needed. The user name information is not appropriate for a public FTP connexion.

Name to use for connection

The designation of the connexion as it will appear in the file manager.

Share

Name of desired windows share. This is only applicable to Windows shares.

Domain name

Windows domain. This is only applicable to Windows shares.

If the server information is provided in the form of a URI, or you require a specialized connection, choose Custom
Location as the service type.
Once you have filled in the information, click on the Connect button. When the connection succeeds, the contents of
the site are displayed and you may drag and drop files to and from the remote server.

To Access Network Places
If your system is configured to access places on a network, you can use the file manager to access the network
places.
To access network places, open the file manager and choose Places→Network Servers. A window opens that displays the network places that you can access. Double-click on the network that you want to access.
To access UNIX shares, double-click on the Unix Network (NFS) object. A list of the UNIX shares available to you
is displayed in the file manager window.
To access Windows shares, double-click on the Windows Network (SMB) object. A list of the Windows shares
available to you is displayed in the file manager window.

Accessing Special URI Locations
Nautilus has certain special URI locations that enable you to access particular functions from the file manager. For
example, to access fonts, you can access the fonts:/// URI in a file manager window.
These are intended for advanced users: in most cases, an easier method of accessing the function or location exists.
Table 6.8, “Special URI Locations” lists the special URI locations that you can use with the file manager.
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Table 6.8. Special URI Locations
URI Location

Description

fonts:///

Displays all the fonts that are available in your system. To preview a font,
double-click on the font. You can also use this location to add fonts to the
GNOME Desktop.

burn:///

This is a special location where you can copy files and folders that you want
to write to a CD. From here you can write the contents of the location to a
CD easily. See also the section called “Writing CDs or DVDs”.

network:///

Displays network locations to which you can connect, if your system is configured to access locations on a network. To access a network location,
double-click on the network location. You can also use this URI to add network locations to your system. See also the section called “To Access Network Places”.

themes:///

Displays all the themes that are available in the GNOME Desktop. To apply
a theme to the GNOME Desktop, double-click on the theme. You can also
use this location to add themes to the GNOME Desktop.
Alternatively, set a theme with the Theme preference tool.

Nautilus Preferences
Use the File Management Preferences dialog to customize the file manager to suit your requirements and preferences.
To display the File Management Preferences dialog, choose Edit→Preferences. You can also access this dialog directly from the top panel Menubar by choosing Desktop→Preferences→File Management.
You can set preferences in the following categories:
•

The default settings for views.

•

The behavior of files and folders, executable text files, and Trash.

•

The information that is displayed in icon captions and the date format.

•

The columns that appear in the list view and their order.

•

Preview options to improve the performance of the file manager.

Views Preferences
You can specify a default view, and select sort options and display options. You can also specify default settings for
icon views and list views.
To specify your default view settings, choose Edit→Preferences. Click on the Views tab to display the Views tabbed
section.
Table 6.9, “Views Preferences” lists the views preferences that you can modify.
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Table 6.9. Views Preferences
Dialog Element

Description

View new folders using

Select the default view for folders. When you open a folder, the folder is
displayed in the view that you select. This can be either the icon view or
the list view.

Arrange items

Select the characteristic by which you want to sort the items in folders that
are displayed in this view.

Sort folders before files

Select this option to list folders before files when you sort a folder.

Show hidden and backup files

Select this option to display files that are normally not shown in folders.
For more on hidden files, see the section called “Hidden Files”.

Icon View Default zoom level

There are two settings, one for the icon view and one for the list view. Select the default zoom level for folders that are displayed in this view. The
zoom level specifies the size of items in a view.

Use compact layout

Select this option to arrange the items in icon view so that the items in the
folder are closer to each other.

Text beside icons

Select this option to place the icon captions for items beside the icon rather
than under the icon.

Show only folders

Select this option to display only folders in the Tree in the side pane.

Behavior Preferences
To set your preferences for files and folders, choose Edit→Preferences. Click on the Behavior tab to display the Behavior tabbed section.
Table 6.10, “File and Folder Behavior Preferences” lists the preferences that you can modify for files and folders.

Table 6.10. File and Folder Behavior Preferences
Option

Description

Single click to activate items

Select this option to perform the default action for an item when you click
on the item. When this option is selected, and you point to an item, the title
of the item is underlined.

Double click to activate items

Select this option to perform the default action for an item when you
double-click on the item.

Always open in browser windows

Select this option to use nautilus in browser mode rather than spatial mode.
Selecting this lets you browse your files and folders in the same window,
otherwise you will navigate your files and folders as objects.

Always use text entry location bar.

Select this option to force Nautilus to use the Location bar in location field
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Description
mode instead of the button bar mode by default. For more on using the location bar see the section called “Using the Location Bar”.

Run executable text files when they are Select this option to run an text executable file when you choose the file.
clicked
An executable text file is a text file that can execute, that is, a shell script.
View executable text files when they Select this option to display the contents of an executable text file when
are clicked
you choose the executable text file.
Ask each time

Select this option to display a dialog when you choose an executable text
file. The dialog asks whether you want to execute the file or display the
file.

Ask before emptying the Trash or delet- Select this option to display a confirmation message before Trash is emping files
tied, or files are deleted. Leave this selected unless you have good reason
not to.
Include a Delete command that by- Select this option to add a Delete menu item to the following menus:
passes Trash
• The Edit menu.
•

The popup menu that is displayed when you right-click on a file,
folder, or desktop object.

When you select an item then choose the Delete menu item, the item is deleted from your file system immediately. There is no way to recover a deleted file. Do not select this unless you have good reason to.

Display Preferences
An icon caption displays the name of a file or folder in an icon view. The icon caption also includes three additional
items of information on the file or folder. The additional information is displayed after the file name. Normally only
one item of information is visible, but when you zoom in on an icon, more of the information is displayed. You can
modify what additional information is displayed in icon captions.
To set your preferences for icon captions, choose Edit→Preferences. Click on the Display tab to display the Display
tabbed section.
Select the items of information that you want to display in the icon caption from the three drop-down lists. Select the
first item from the first drop-down list, select the second item from the second drop-down list, and so on. The following table describes the items of information that you can select:
Information

Description

Size

Choose this option to display the size of the item.

Type

Choose this option to display the description of the MIME type of the item.

Date modified

Choose this option to display the last modification date of the item.

Date accessed

Choose this option to display the date that the item was last accessed.

Owner

Choose this option to display the owner of the item.
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Information

Description

Group

Choose this option to display the group to which the item belongs.

Permissions

Choose this option to display the permissions of the item as three sets of
three characters, for example -rwxrw-r--.

Octal permissions

Choose this option to display the permissions of the item in octal notation,
for example 764.

MIME type

Choose this option to display the MIME type of the item.

None

Choose this option to display no information for the item.

The date Format option lets you choose how the date is displayed throughout Nautilus.

List Columns Preferences
You can specify what information is displayed in list view in file manager windows. You can specify which
columns are displayed in list view, and the order in which the columns are displayed.
To set your preferences for list columns, choose Edit→Preferences. Click on the List Columns tab to display the List
Columns tabbed section.
To specify a column to display in list view, select the option that corresponds to the column, then click on the Show
button. To remove a column from the list view, select the option that corresponds to the column, then click on the
Hide button.
Use the Move Up and Move Down buttons to specify the position of columns in list view.
To use the default columns and column positions, click on the Use Default button.
The following table describes the columns that you can display:
Information

Description

Name

Choose this option to display the name of the item.

Size

Choose this option to display the size of the item.

Type

Choose this option to display the description of the MIME type of the item
from the File Types and Programs preference tool.

Date Modified

Choose this option to display the last modification date of the item.

Date Accessed

Choose this option to display the date that the item was last accessed.

Group

Choose this option to display the group to which the item belongs.

MIME type

Choose this option to display the MIME type of the item.

Octal Permissions

Choose this option to display the permissions of the item in octal notation,
for example 764.
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Information

Description

Owner

Choose this option to display the owner of the item.

Permissions

Choose this option to display the permissions of the item as three sets of
three characters, for example -rwxrw-r--.

Preview Preferences
The file manager include some file preview features. The preview features can affect the speed with which the file
manager responds to your requests. You can modify the behavior of some of these features to improve the speed of
the file manager. For each preview preference, you can select one of the options described in the following table:
Option

Description

Always

Performs the action for both local files, and files on other file systems.

Local Files Only

Performs the action for local files only.

Never

Never performs the action.

To set your preview preferences, choose Edit→Preferences. Click on the Preview tab dialog to display the Preview
tabbed section.
Table 6.11, “Preview Preferences” lists the preview preferences that you can modify.

Table 6.11. Preview Preferences
Dialog Element

Description

Show text in icons

Select an option to specify when to preview the content of text files in the
icon that represents the file.

Show thumbnails

Select an option to specify when to show thumbnails of image files. The
file manager stores the thumbnail files for each folder in a .thumbnails
directory in the user's Home Folder.

Only for files smaller than

Specify the maximum file size for files for which the file manager creates
a thumbnail.

Preview sound files

Select an option to specify when to preview sound files.

Count number of items

Select an option to specify when to show the number of items in folders.
When in icon view, you might need to increase your zoom level to see the
number of items in each folder.
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Extending Nautilus
Nautilus can be extended in two main ways. Through nautilus extensions, and through scrips. This section explains
the difference between the two and how to install.

Nautilus Scripts
Nautilus can run scripts. Scripts are typically simpler in operation than full Nautilus extensions and can be written in
any scripted language capable of being executed on your computer. To run a script choose File→Scripts, then
choose the script that you want to run from the submenu.
To run a script on a particular file, select the file in the view pane. Choose File→Scripts, then choose the script that
you want to run on the file from the submenu. You can also select multiple files to run your scripts on.
You may also access scripts from the context menu.
If you do not have any scripts installed, the script menu will not appear.

Installing File Manager Scripts
The file manager includes a special folder where you can store your scripts. All executable files in this folder will
appear in the Scripts menu. The script folder is located at $HOME/.gnome2/nautilus-scripts.
To install a script, simply copy the script to the script folder and give it the user executable permission.
To view the contents of your scripts folder, if you already have scripts installed, choose File→Scripts→Open Scripts
Folder. You will have to navigate to the scripts folder with the file manager if you do not yet have any scripts. You
may need to show hidden files for this, use View→Show Hidden Files
A good source to download Nautilus scripts is from the G-Scripts website.

Writing File Manager Scripts
When executed from a local folder, scripts will be passed the selected file names. When executed from a remote
folder (e.g. a folder showing web or ftp content), scripts will be passed no parameters.
The following table shows variables passed to the script :
Environment variable

Description

NAUTILUS_SCRIPT_SELECTED_FILE_PATHS

newline-delimited paths for selected files (only if local)

NAUTILUS_SCRIPT_SELECTED_URIS

newline-delimited URIs for selected files

NAUTILUS_SCRIPT_CURRENT_URI

URI for current location

NAUTILUS_SCRIPT_WINDOW_GEOMETRY

position and size of current window
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Nautilus Extensions
Nautilus extensions are far more powerful than Nautilus scripts, allowing more freedom where and how they extend
Nautilus. Nautilus extensions are typically installed by your system administrator.
Some popular Nautilus extensions include:
1.

nautilus-actions
This extension allows you to easily assign actions based on file type

2.

nautilus-send-to
This extension provides a simple way to send a file or folder to another using email, instant messaging, or
Bluetooth.

3.

nautilus-open-terminal.
This extension provides an easy way to open a terminal at the selected starting location.

If you are looking for the Open Terminal command which used to exist in the Nautilus right click
menu by default then you should install the nautilus-open-terminal extension.
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Running Applications

This section describes some of the tools and utilities in the GNOME Desktop.

Running Applications
The Run Application dialog gives you access to the command line. When you run a command in the Run Application dialog, you cannot receive output from the command.
To run a command from the command line perform the following steps:
1.

Display the Run Application dialog. You can display the Run Application dialog in any of the following ways:
From a panel
You can add the Run Application object to any panel. See the section called “Adding an Object to a Panel”.
Click on the Run button to open the Run Application dialog.
Using shortcut keys
Press Alt-F2. You can change the shortcut keys that display the Run Application dialog in the Keyboard Shortcuts preference tool.
The Run Application dialog is displayed.

2.

Enter the command that you want to run in the blank field.
Alternatively, to choose a command that you ran previously, click the down arrow button beside the command
field, then choose the command to run.
Alternatively, select the Show list of known applications option to display a list of available applications.
You can also use the Run with file button to choose a file to append to the command line. For example, you can
enter emacs as the command, then choose a file to edit.
Select the Run in terminal option to run the application or command in a terminal window. Choose this option
for an application or command that does not create a window in which to run.

3.

Click on the Run button on the Run Application dialog.

Taking Screenshots
You can take a screenshot in any of the following ways:
•

From any panel
You can add a Take Screenshot button to any panel. For instructions on how to do this, see the section called
“Adding an Object to a Panel”. Click on the Take Screenshot button to take a screenshot of the entire screen.

•

Use shortcut keys
To take a screenshot, use the following shortcut keys:

Default Shortcut Keys

Function

Print Screen

Takes a screenshot of the entire screen.

Alt-Print Screen

Takes a screenshot of the window to which the mouse points.

You can use the Keyboard Shortcuts preference tool to modify the default shortcut keys.
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From the Menubar
Choose Applications→Accessories→Take Screenshot.

•

From the Terminal
You can use the gnome-panel-screenshot command to take a screenshot. The gnome-panel-screenshot command takes a screenshot of the entire screen, and displays the Save Screenshot dialog. Use the Save Screenshot
dialog to save the screenshot.
You can also use options on the gnome-panel-screenshot command as follows:

Option

Function

--window

Takes a screenshot of the window that has focus.

--delay=seconds

Takes a screenshot after the specified number of seconds, and displays the
Save Screenshot dialog. Use the Save Screenshot dialog to save the
screenshot.

--help

Displays the options for the command.

When you take a screenshot, the Save Screenshot dialog opens. To save the screenshot as an image file, enter the filename for the screenshot and choose a location from the drop-down list.

Yelp Help Browser
Introduction
The Yelp Help Browser application allows you to view documentation regarding GNOME and other components
through a variety of formats. These formats include docbook files, HTML help pages, man pages and info pages
(support for man pages and info pages may optionally be compiled in). Despite the different formats supported, Yelp
does its best to provide a unified look and feel regardless of the original document format.
Yelp Help Browser is internationalised, meaning that it has support to view documents in different languages. The
documents must be localised or translated for each language and installed properly for Yelp Help Browser to be able
to view them.

Starting Yelp
To Start Yelp Help Browser
You can start Yelp Help Browser in the following ways:
System Menu
Choose Help
Command Line
Execute the following command: yelp

Interface
When you start Yelp Help Browser, you will see the following window appear.
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Figure 7.1. Yelp Help Browser Window

Yelp Help Browser contains the following elements in Figure 7.1, “Yelp Help Browser Window”
Menubar
File
Use this menu to Open a New Window, view the About this Document page, Print the current document, or
Close the window.
Edit
Use this menu to Copy, Select all, Find..., or to set your Preferences.
Go
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Use this menu to navigate Back, Forward, to the Help Topics page. When viewing a DocBook document, use
this menu to navigate to the Next Section, Previous Section or to the Contents.
Bookmarks
Use this menu to Add Bookmark(s), or Edit Bookmark(s).
Help
View information about Yelp Help Browser and contributors to the project through the About menuitem. Open
this document with the Contents menuitem or by pressing F1.
Toolbar
Back
Use this button to navigate back in your document history.
Forward
Use this button to navigate forward in your document history.
Help Topics
Use this button to return to the main table of contents (shown in Figure 7.1, “Yelp Help Browser Window”)
Browser Pane
The browser pane is where you will be presented with the table of contents or the documentation. Use the table
of contents to navigate to the documentation you need.

Using Yelp
Open a Document
To open a document in Yelp Help Browser, use the Table of Contents to navigate to the desired document
Alternatively, you may view a particular document by invoking Yelp Help Browser from the command line. Please
see Using the Command Line to Open Documents.

Open a New Window
To open a new window:
•

Click File→New Window

•

Use the key combination Ctrl+N

About This Document
To view information about the currently open document:
•

Click File→About This Document
This option is only available for DocBook documentation. Legal notices and documentation contributors are usually listed in this section.

Print a Page
To print any page that you are able to view in Yelp Help Browser:
•

Click File→Print this Page
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Print a Document
To print an entire document:
•

Click File→Print this Document
This option is only available for DocBook documentation.

Close a Window
To close a window in Yelp Help Browser, do the following:
•

Click File→Close Window

•

Use the key combination Ctrl+W

Set Preferences
To set your preferences in Yelp Help Browser:
• Click Edit→Preferences
A window will appear that looks like Figure 7.2, “Yelp Help Browser Preferences Window”:

Figure 7.2. Yelp Help Browser Preferences Window

The options that are available in this dialog have the following functions:
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Use system fonts
Check this option to display documentation using the default fonts used by the GNOME Desktop.
To choose your own fonts to display documentation, uncheck this option and click on the buttons next to the
text Variable Width or Fixed Width.
Variable Width
This is the font to use when a static or fixed width font is not required. The majority of text will be of this type.
Fixed Width
This is the font to use when all text characters need to be of the same size. This font is usually used to indicate
commands, program blocks, or other text that falls under these categories.
Browse with caret
Click this option if you would like see a caret or cursor in the Yelp Browser Pane. This allows you to browse
the document more easily by showing where the cursor is located in the document.

Go Back in Document History
To go back in the document history:
•

Click Go→Back

•

Use the key combination Alt+Left

•

Use the Back button in the Toolbar

Go Forward in Document History
To go forward in the document history:
•

Click Go→Forward

•

Use the key combination Alt+Right

•

Use the Forward button in the Toolbar

Go to Help Topics
To go to the Help Topics:
•

Click Go→Help Topics

•

Use the key combination Alt+Home

•

Use the Help Topics button in the Toolbar

Go to Previous Section
To go to the previous section:
•

Click Go→Previous Section

•

Use the key combination Alt+Up
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This option is only available in DocBook formatted documents.

Go to Next Section
To go to the next section:
•

Click Go→Next Section

•

Use the key combination Alt+Down
This option is only available in DocBook formatted documents.

Go to Contents
To go to the contents for a document:
•

Click Go→Contents
This option is only available in DocBook formatted documents.

Add a Bookmark
To add a bookmark for a particular document:
•

Click Bookmarks→Add Bookmark

• Use the key combination Ctrl+D
A window will appear that looks like Figure 7.3, “Add Bookmark Window”.

Figure 7.3. Add Bookmark Window

Enter your desired bookmark title in to the Title text entry field. Then click Add to add the bookmark, or click Cancel to cancel the request.
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Edit Bookmarks
To edit your collection of bookmarkst:
•

Click Bookmarks→Edit Bookmarks...

• Use the key combination Ctrl+B
A window will appear that looks like Figure 7.4, “Edit Bookmarks Window”.

Figure 7.4. Edit Bookmarks Window

You can manage your bookmarks using this window in the following ways:
Open
Use this button to open the selected bookmark in a new window.
Rename
Use this button to rename the title of your bookmark.
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Remove
Use this button to delete the bookmark from your collection.
Once you are finished managing your bookmarks, click the Close button to exit the Edit Bookmarks Window.

Get Help
To get help using Yelp Help Browser (and see this document):
•

Click Help→Contents

Advanced Features
Using the Command Line to Open Documents
Yelp Help Browser supports opening documents from the command line. There are a number of URIs (Uniform Resource Identifiers) that can be used. These include:
file:
Use this URI when you want to access a file with yelp, for example:
yelp file:///usr/share/gnome/help/gcalctool/C/gcalctool.xml
ghelp: or gnome-help:
Use this URI when you want to access GNOME help documents, which are typically written in DocBook
format.
yelp ghelp:gcalctool
If you want to open the help document at a particular section, append a question mark to the end of the URI, followed by the section id.
yelp ghelp:user-guide?yelp-advanced-cmdline
man:
Use this URI when you want to access a particular man page. You can append the section of the man page you
would like to view if there are multiple man pages with the same name. The section number should be enclosed
in parenthesis and therefore it may be necessary to escape the argument so that the shell does not interpret the
parenthesis.
yelp man:gcalctool
or
yelp 'man:intro(1)'
yelp 'man:intro(2)'
info:
Use this URI when you want to access a particular GNU info page.
yelp info:make

Refreshing Content on Demand
Yelp Help Browser supports the Ctrl-R shortcut keys, which will reload the DocBook document that is currently
open. This allows developers to view changes to documents as they are made.
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More Information
This section details some of the helper applications which Yelp Help Browser uses, and provides resources where
you can get more information about Yelp Help Browser.

Scrollkeeper
Yelp Help Browser uses scrollkeeper to generate the table of contents for DocBook and HTML documentation, and
also keep track of translations for each document.

GNOME Documentation Utilites
The documentation distributed with GNOME uses this set of utilities for a variety of things:
•

Ease translation of documents to different languages.

•

Provide a set of tools to help package and install documentation into the correct location and register the documentation with scrollkeeper.

• Perform conversion from DocBook format to a format suitable for display.
Yelp Help Browser relies on GNOME XSLT Stylesheets to perform conversion from DocBook to HTML. GNOME
Documentation Build Utilities are relied upon by application authors to install and register documentation within the
help system.

Mailing List
For further information
doc-devel-list@gnome.org.

on

Yelp

Help

Browser

please

subscribe

to

the

mailing

list,

gnome-

Joining the GNOME Documentation Project
If you are interesting in helping produce and update documentation for the GNOME project, please visit the following link: http://live.gnome.org/DocumentationProject
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Assistive Technology Preferences

This chapter describes how to use the preference tools to customize the GNOME Desktop.
A preference tool is a small application that allows you to change settings in the GNOME Desktop. Each preference
tool covers a particular aspect of your computer. For example, with the Mouse preference tool you can set your
mouse to left-handed or right-handed use, or change the speed of the pointer on the screen. With the Windows preference tool you can set behaviour common to all windows such as the way in which you select them with the mouse.
To open a preference tool, choose Desktop→Preferences in the top panel. Choose the tool that you require from the
submenu.
With a few exceptions, the changes you make to settings in a preference tool take effect immediately, without needing to close the preference tool. You can keep the preference tool window open while you try the changes, and make
further changes if you wish.
Some applications or system components may add their own preference tools to the menu.
Some settings for your system require administrator access. These are in the Desktop→Administration
submenu.

Assistive Technology Preferences
Use the Assistive Technology preference tool to enable assistive technologies in the GNOME Desktop. You can also
use the Assistive Technology preference tool to specify assistive technology applications to start automatically when
you log in.
Table 8.1, “Assistive Technology Preferences” lists the assistive technology preferences that you can modify.

Table 8.1. Assistive Technology Preferences
Dialog Element

Description

Enable assistive technologies

Select this option to enable assistive technologies in the
GNOME Desktop.

Screenreader

Select this option to start the Screenreader application
automatically when you log in.

Magnifier

Select this option to start the Magnifier application automatically when you log in.

On-screen keyboard

Select this option to start the On-screen keyboard application automatically when you log in.
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CD Database Preferences
The CD Database preference tool enables you to configure a CD database that your system can query. A CD database contains information about CDs, such as the name of the artist, the title, and the track list. When an application
plays a CD, the application can query the CD database about the CD, then display the information.
Not all applications that use audio CDs use the settings in this preference tool. Some may have supply
their own settings in their preference dialog.
Table 8.2, “CD Database Preferences” describes the preferences in the CD Database preference tool.

Table 8.2. CD Database Preferences
Dialog Element

Description

Send no information

Select this option if you do not want to send any information to the CD database
server.

Send real information

Select this option to send your name and hostname information to the CD database
server.

Send other information

Select this option to send another name and hostname to the CD database server.
Enter the name in the Name field. Enter the hostname in the Hostname field.

FreeDB round robin server

FreeDB is a CD database. The FreeDB round robin server is a load-sharing configuration of FreeDB servers. Select this option to access the FreeDB CD database
from this server.

Other FreeDB server

Select this option to access the FreeDB CD database from another server. Select
the server that you require from the server table.

Update Server List

Click on this button to update the list of available FreeDB servers in the server table.

Other server

Select this option to use another CD database. Enter the name of the server on
which the database resides in the Hostname field. Enter the port number on which
you can access the database in the Port field.

Desktop Background Preferences
The desktop background is the image or color that is applied to your desktop. You can open Desktop Background
Preferences by right-clicking on the desktop and choosing Change Desktop Background, as well as from the
Desktop→Preferences menu.
You can customize the desktop background in the following ways:
•

Select an image for the desktop background. The image is superimposed on the desktop background color. The
desktop background color is visible if you select a transparent image, or if the image does not cover the entire
desktop.
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•

Desktop Background Preferences

Select a color for the desktop background. You can select a solid color, or create a gradient effect with two colors. A gradient effect is a visual effect where one color blends gradually into another color.
You can also drag a color or a pattern to the desktop from the Backgrounds and Emblems dialog in the
Nautilus file manager.

Table 8.3, “Desktop Background Preferences” lists the background preferences that you can modify.

Table 8.3. Desktop Background Preferences
Dialog Element

Description

Desktop Wallpaper

Choose an image from the list. Alternately, you can select Add Wallpaper to
choose any image on your computer.

Style

To specify how to display the image, select one of the following options from the
Style drop-down list:
•

Centered: Displays the image in the middle of the desktop.

•

Fill Screen: Enlarges the image to cover the desktop and maintains the relative
dimensions of the image.

•

Scaled: Enlarges the image until the image meets the screen edges, and maintains the relative dimensions of the image.

•

Tiled: Enlarges the image until the image meets the screen edges, and maintains the relative dimensions of the image.

Add Wallpaper
Click on Add Wallpaper to browse for an image on your computer. A standard file
selector will be presented. Choose the image you want and click Open.
Remove

Choose the Desktop Wallpaper that you want to remove, then click Remove. This
removes the image from the list of available wallpapers; however, it does not delete the image from your computer.

Desktop Colors

To specify a color scheme, use the options in the Background Style drop-down
list, and the color selector buttons.
You can specify a color scheme in one of the following ways:
•

Choose Solid color from the Background Style drop-down list to specify a
single color for the desktop background.
To choose the color that you require, click on the Color button. The Pick a
Color dialog is displayed. Choose a color, then click OK.

•

Choose Horizontal gradient from the Background Style drop-down list. This
option creates a gradient effect from the left screen edge to the right screen
edge.
Click on the Left Color button to display the Pick a Color dialog. Choose the
color that you want to appear at the left edge.
Click on the Right Color button. Choose the color that you want to appear at
the right edge.
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Dialog Element

File Management Preferences

Description
•

Choose Vertical gradient from the Background Style drop-down list. This creates a gradient effect from the top screen edge to the bottom screen edge.
Click on the Top Color button to display the Pick a Color dialog. Choose the
color that you want to appear at the top edge.
Click on the Bottom Color button. Choose the color that you want to appear at
the bottom edge.

File Management Preferences
Use the File Management preference tool to set your Nautilus file manager preferences. You can also set your file
manager preferences in the File Management preferences dialog, which you can open from the file manager application. For information on the preferences in the File Management preferences dialog and File Management preference tool, see the section called “Nautilus Preferences”.

Font Preferences
Use the Font preference tool to select the fonts to use in your applications, windows, terminals, and desktop.
Table 8.4, “Font Preferences” lists the font preferences that you can modify.

Table 8.4. Font Preferences
Dialog Element

Description

Application font

Click on the font selector button to select a font to use in your applications.

Desktop font

Click on the font selector button to select a font to use on your desktop only.

Window title font

Click on the font selector button to select a font to use in the titlebars of your windows.

Terminal font

Click on the font selector button to select a font to use in the Terminal application

Font Rendering

To specify how to render fonts on your screen, select one of the following options:
•

Monochrome: Renders fonts in black and white only. The edges of characters
might appear jagged in some cases because the characters are not antialiased.
Antialiasing is an effect that is applied to the edges of characters to make the
characters look smoother.

•

Best shapes: Antialiases fonts where possible. Use this option for standard
Cathode Ray Tube (CRT) monitors.

•

Best contrast: Adjusts fonts to give the sharpest possible contrast, and also antialiases fonts, so that characters have smooth edges. This option might enhance the accessibility of the GNOME Desktop to users with visual impairments.
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Dialog Element

Description
•

Details

Font Preferences

Subpixel smoothing (LCDs): Uses techniques that exploit the shape of individual Liquid Crystal Display (LCD) pixels to render fonts smoothly. Use this
option for LCD or flat-screen displays.

Click on this button to specify further details of how to render fonts on your
screen.

Go to font folder

•

Resolution (dots per inch): Use the spin box to specify the resolution to use
when your screen renders fonts.

•

Smoothing: Select one of the options to specify how to antialias fonts.

•

Hinting: Hinting is a font-rendering technique that improves the quality of
fonts at small sizes and an at low screen resolutions. Select one of the options
to specify how to apply hinting your fonts.

•

Subpixel order: Select one of the options to specify the subpixel color order
for your fonts. Use this option for LCD or flat-screen displays.

Click on this button to open the Fonts folder.

Previewing a Font
A preview of a font shows the characters of a font at different sizes, as well as copyright and technical information.
To preview a font, perform the following steps:
1.

Open the Font preference tool by choosing Desktop→Preferences→Font in the top panel.

2.

Click on Details.

3.

Click on Go to font folder. The Fonts folder opens.

4.

Open a font to display a preview.

Adding a TrueType Font
To add a TrueType font to your system, perform the following steps:
1.

Open the Font preference tool by choosing Desktop→Preferences→Font in the top panel.

2.

Click on Details.

3.

Click on Go to font folder. The Fonts folder opens.

4.

Open a file manager window and select the TrueType font that you want to add.

5.

Copy the TrueType font file that you want to add to the Fonts folder.
You can also open the Fonts folder by typing the following URI into Nautilus file manager's Open
Location dialog: fonts:///.
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Login Photo Preferences
The Login Photo preference tool enables you to change the picture that is displayed in your login screen.
From the Login Photo preference tool, select an image to display in your login screen. Type the path for the folder
from where you want to select your image. Alternatively, click Browse to display a dialog from which you can select an image to display as your photograph and click OK.

Keyboard Accessibility Preferences
The Keyboard Accessibility preference tool allows you to set options such as filtering out accidental keypresses, using the keyboard as a substitute for the mouse, and using shortcut keys without having to hold down several keys at
once. The Keyboard accessibility preference tool is also known as AccessX.
This section describes each of the preferences you can set. For a more task-oriented description of keyboard accessibility, see the GNOME Desktop Accessibility Guide.
To open the Keyboard Accessibility preference tool, do one of the following:
•

From the Main Menu, choose Desktop→Preferences→Accessibility→Keyboard.

•

In the Keyboard preference tool, click the Accessibility button.

You can customize the preferences for the keyboard accessibility in the following functional areas:
•

Basic

•

Filters

•

Mouse

Basic Preferences
Table 8.5, “Keyboard Accessibility Preferences” lists the basic keyboard accessibility preferences that you can
modify.

Table 8.5. Keyboard Accessibility Preferences
Dialog Element

Description

Enable keyboard accessibil- Select this option to enable keyboard accessibility features. When you select this opity features
tion, the other options in the preference tool become available.
Disable if unused for

Select this option to deactivate keyboard accessibility preferences if the keyboard is
not used for a specified period of time. Use the slider to specify the number of
seconds of keyboard idle time required before the system disables the keyboard accessibility preferences. When the specified number of seconds elapses, the following
keyboard accessibility preferences are disabled:
•

Bounce keys

•

Mouse keys

•

Slow keys
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Dialog Element

Keyboard Accessibility Preferences

Description
•

Sticky keys

•

Toggle keys

Beep when features turned Select this option for an audible indication when a feature such as sticky keys or slow
on or off from keyboard
keys is activated, or deactivated.
Import Feature Settings

Click on this button to import an AccessX configuration file.

Enable Sticky Keys

Select this option to perform multiple simultaneous keypress operations by pressing
the keys in sequence. Alternatively, to enable the sticky keys feature, press Shift five
times.
You can set the following sticky keys preferences:

Enable Repeat Keys

Type to test settings

•

Beep when modifier is pressed: Select this option for an audible indication when
you press a modifier key.

•

Disable if two keys pressed together: Select this option to specify that when you
press two keys simultaneously, you can no longer press keys in sequence to perform multiple simultaneous keypresses.

Select this option to enable the autorepeat settings for your keyboard. You can set the
following autorepeat preferences:
•

Delay: Use the slider or the spin box to specify the interval to wait after the first
keypress before the automatic repeat of a pressed key.

•

Speed: Use the slider or the spin box to specify the number of characters per
second to enter.

The test area is an interactive interface so you can see how the keyboard settings affect the display as you type. Type text in the test area to test the effect of your settings.

For more information on configuring keyboard accessibility preferences, see the GNOME Desktop Accessibility
Guide.

Filter Preferences
Table 8.6, “Filter Preferences” lists the filter preferences that you can modify.

Table 8.6. Filter Preferences
Dialog Element

Description

Enable keyboard accessibil- Select this option to enable keyboard accessibility features. When you select this opity features
tion, the other options in the preference tool become available.
Enable Slow Keys

Select this option to control the period of time that you must press-and-hold a key before acceptance. Alternatively, to enable the slow keys feature, press-and-hold Shift
for eight seconds.
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Dialog Element

Keyboard Accessibility Preferences

Description
You can set the following slow keys preferences:

Enable Bounce Keys

•

Only accept keys held for: Use the slider or the spin box to specify the period of
time that you must press-and-hold a key before acceptance.

•

Beep when key is: Select the appropriate option or options for an audible indication when a key is pressed, accepted, or rejected.

Select this option to accept a key input and to control the key repeat characteristics of
the keyboard. You can set the following bounce keys preferences:
•

Ignore duplicate keypresses within: Use the slider or the spin box to specify the
interval to wait after the first keypress before the automatic repeat of a pressed
key.

•

Beep if key is rejected: Select this option for an audible indication of key rejection.

Enable Toggle Keys

Select this option for an audible indication of a toggle keypress. You hear one beep
when a toggle key is turned on. You hear two beeps when a toggle key is turned off.

Type to test settings

The test area is an interactive interface so you can see how the keyboard settings affect the display as you type. Type text in the test area to test the effect of your settings.

For more information on configuring keyboard accessibility preferences, see the GNOME Desktop Accessibility
Guide.

Mouse Preferences
Table 8.7, “Mouse Preferences” lists the mouse preferences that you can modify.

Table 8.7. Mouse Preferences
Dialog Element

Description

Enable keyboard accessibil- Select this option to enable keyboard accessibility features. When you select this opity features
tion, the other options in the preference tool become available.
Enable Mouse Keys

Select this option to make the numeric keypad emulate mouse actions. The list of keys
and their equivalences is in the GNOME Desktop Accessibility Guide under the heading To Enable the Keyboard to Emulate the Mouse.
You can set the following mouse key preferences:
•

Maximum pointer speed: Use the slider or the spin box to specify the maximum
speed that the pointer moves across the screen.

•

Time to accelerate to maximum speed: Use the slider or the spin box to specify
the duration of the acceleration time of the pointer.

•

Delay between keypress and pointer movement: Use the slider or the spin box to
specify the period of time that must pass after a keypress before the pointer
moves.
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Keyboard Preferences

Dialog Element

Description

Mouse Preferences

Click on this button to open the Mouse preference tool.

For more information on configuring keyboard accessibility preferences, see the GNOME Desktop Accessibility
Guide.

Keyboard Preferences
Use the Keyboard preference tool to modify the autorepeat preferences for your keyboard, and to configure typing
break settings.
You can set the preferences for the Keyboard preference tool in the following functional areas:
•

Keyboard

•

Typing Break

•

Layouts

•

Layout Options

Keyboard Preferences
Use the Keyboard tabbed section to set general keyboard preferences. To start the Keyboard accessibility preference
tool, that is, AccessX, click on the Accessibility button.
Table 8.8, “Keyboard Preferences” lists the keyboard preferences that you can modify.

Table 8.8. Keyboard Preferences
Dialog Element

Description

Key presses repeat when key is Select this option to enable keyboard repeat. If keyboard repeat is enabled, when
held down
you press-and-hold a key, the action associated with the key is performed repeatedly. For example, if you press-and-hold a character key, the character is
typed repeatedly.
Delay

Select the delay from the time you press a key to the time that the action repeats.

Speed

Select the speed at which the action is repeated.

Cursor blinks in text boxes and Select this option to enable the cursor to blink in fields and text boxes.
fields
Speed

Use the slider to specify the speed at which the cursor blinks in fields and text
boxes.

Type to test settings

The test area is an interactive interface so you can see how the keyboard settings
affect the display as you type. Type text in the test area to test the effect of your
settings.
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Typing Break Preferences
Use the Typing Break tabbed section to set typing break preferences. To start the Keyboard accessibility preference
tool, that is, AccessX, click on the Accessibility button.
Table 8.9, “Typing Break Preferences” lists the typing break preferences that you can modify.

Table 8.9. Typing Break Preferences
Dialog Element

Description

Lock screen to enforce typing break

Select this option to lock the screen when you are due a
typing break.

Work interval lasts

Use the spin box to specify how long you can work before a typing break occurs.

Break interval lasts

Use the spin box to specify the length of your typing
breaks.

Allow postponing of breaks

Select this option if you want to be able to postpone typing breaks.

Keyboard Layout Preferences
Use the Layouts tabbed section to set your keyboard layout. Select your keyboard model from the drop-down list.
Use the navigational buttons to add or remove a selected layout from the list of available layouts.
You can choose different layouts to suit different locales. For more information on keyboard layouts, see the Keyboard Layout Switcher manual.
To start the Keyboard accessibility preference tool, that is, AccessX, click on the Accessibility button.

Keyboard Layout Options
Use the Layout Options tabbed section to set your keyboard layout options. Select an option from the list of available layout options and click Add to select an option. Use Remove to remove a selected option.
For more information on the layout options, see the Keyboard Layout Switcher manual.
To start the Keyboard accessibility preference tool, that is, AccessX, click on the Accessibility button.

Keyboard Shortcuts Preferences
A keyboard shortcut is a key or combination of keys that provides an alternative to standard ways of performing an
action.
Use the Keyboard Shortcuts preference tool to display the default keyboard shortcuts. You can customize the default
keyboard shortcuts to your requirements.
Table 8.10, “Keyboard Shortcuts Preferences” lists the keyboard shortcut settings that you can customize.
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Menus & Toolbars Preferences

Table 8.10. Keyboard Shortcuts Preferences
Dialog Element

Description

Text editing shortcuts

Select one of the following settings:

Desktop shortcuts

•

GNOME Default: Use this setting for standard shortcut keys.

•

Emacs: Use this setting for Emacs shortcut keys.

This table lists actions and the shortcut keys that are associated with each
action.
To change the shortcut keys for an action, click on the action to select the
action, then click on the shortcut for the action. Press the keys that you
want to associate with the action.
To disable the shortcut keys for an action, click on the action to select the
action, then click on the shortcut for the action. Press the Backspace key.

Menus & Toolbars Preferences
You can use the Menus & Toolbars preference tool to customize the appearance of menus, menubars, and toolbars
for GNOME-compliant applications.
Table 8.11, “Menu and Toolbar Preferences” lists the menu and toolbar preferences that you can modify for
GNOME-compliant applications.

Table 8.11. Menu and Toolbar Preferences
Dialog Element

Description

Show icons in menus

Select this option to display an icon beside each item in a menu. Some menu items
do not have an icon.

Detachable toolbars

Select this option if you want to move toolbars from application windows to any
location on the screen. If you select this option, handles are displayed on the left
side of the toolbars in your applications. To move a toolbar, click-and-hold on the
handle, then drag the toolbar to the new location.

Toolbar button labels

Choose one of the following options to specify what to display on the toolbars in
your GNOME-compliant applications:
•

Text Below Icons: Select this option to display toolbars with text as well as an
icon on each button.

•

Text Beside Icons: Select this option to display toolbars with an icon only on
each button, and with text on the most important buttons.

•

Icons Only: Select this option to display toolbars with an icon only on each
button.

•

Text Only: Select this option to display toolbars with text only on each button.
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Dialog Element

Mouse Preferences

Description

Mouse Preferences
With the Mouse preference tool you can:
•

configure your mouse for right-hand use or for left-hand use,

•

specify the speed and sensitivity of mouse movement.

Buttons Preferences
Use the Buttons tabbed section to specify whether the mouse buttons are configured for left-hand use. You can also
specify the delay between clicks for a double-click.
Table 8.12, “Mouse Button Preferences” lists the mouse button preferences that you can modify.

Table 8.12. Mouse Button Preferences
Dialog Element

Description

Left-handed mouse

Select this option to configure your mouse for left-hand use. When you configure
your mouse for left-hand use, the functions of the left mouse button and the right
mouse button are swapped.

Timeout

Use the slider to specify the amount of time that can pass between clicks when
you double-click. If the interval between the first and second clicks exceeds the
time that is specified here, the action is not interpreted as a double-click.
Use the light bulb icon to check double-click sensitivity: the light will light up
briefly for a click, but stay lit for a double-click.

Pointer Preferences
Use the Pointers tabbed section to set your mouse pointer preferences.
Table 8.13, “Mouse Pointer Preferences” lists the mouse pointer preferences that you can modify:

Table 8.13. Mouse Pointer Preferences
Dialog Element

Description

Pointer Theme

Select the mouse pointer theme that you require from the
list box.

Highlight the pointer when you press Ctrl

Select this option to enable a mouse pointer animation
when you press and release Ctrl. This feature can assist
you to locate the mouse pointer.
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Multimedia Systems Selector

Motion Preferences
Use the Motion tabbed section to set your preferences for mouse movement.
Table 8.14, “Mouse Motion Preferences” lists the mouse motion preferences that you can modify:

Table 8.14. Mouse Motion Preferences
Dialog Element

Description

Acceleration

Use the slider to specify the speed at which your mouse pointer moves on your
screen when you move your mouse.

Sensitivity

Use the slider to specify how sensitive your mouse pointer is to movements of
your mouse.

Threshold

Use the slider to specify the distance that you must move an item before the
move action is interpreted as a drag-and-drop action.

Multimedia Systems Selector
See the GStreamer Properties Manual.

Network Proxy Preferences
The Network Proxy preference tool enables you to configure how your system connects to the Internet. You can
configure the GNOME Desktop to connect to a proxy server, and specify the details of the proxy server. A proxy
server is a server that intercepts requests to another server, and fulfills the request itself, if it can. You can enter the
Domain Name Service (DNS) name or the Internet Protocol (IP) address of the proxy server. A DNS name is a
unique alphabetic identifier for a computer on a network. An IP address is a unique numeric identifier for a computer on a network.
Table 8.15, “Internet Connection Preferences” lists the Internet connection preferences that you can modify.

Table 8.15. Internet Connection Preferences
Dialog Element

Description

Direct internet connection

Select this option if you want to connect directly to the Internet, without a
proxy server.

Manual proxy configuration

Select this option if you want to connect to the Internet through a proxy
server, and you want to configure the proxy server manually.

HTTP proxy

Enter the DNS name, or the IP address of the proxy server to use when you
request a HTTP service. Enter the port number of the HTTP service on the
proxy server in the Port spin box.

Secure HTTP proxy

Enter the DNS name, or the IP address of the proxy server to use when you
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Dialog Element

Preferred Applications

Description
request a Secure HTTP service. Enter the port number of the Secure HTTP
service on the proxy server in the Port spin box.

FTP proxy

Enter the DNS name, or the IP address of the proxy server to use when you
request a FTP service. Enter the port number of the FTP service on the
proxy server in the Port spin box.

Socks host

Enter the DNS name, or the IP address of the Socks host to use. Enter the
port number for the Socks protocol on the proxy server in the Port spin
box.

Automatic proxy configuration

Select this option if you want to connect to the Internet through a proxy
server, and you want to configure the proxy server automatically.

Autoconfiguration URL

Enter the URL that contains the information required to configure the
proxy server automatically.

Preferred Applications
Use the Preferred Applications preference tool to specify the applications that you want the GNOME Desktop to use
when the GNOME Desktop starts an application for you. For example, you can specify Xterm as your preferred terminal application. When you open the Desktop menu then choose Open Terminal, Xterm starts.
You can customize the preferences for the Preferred Applications preference tool in the following functional areas.
•

Web Browser

•

Mail Reader

•

Text Editor

•

Terminal

Web Browser Preferences
Use the Web Browser tabbed section to configure your preferred web browser. The preferred web browser opens
when you click on a URL. For example, the preferred web browser opens when you select a URL in an application,
or when you select a URL launcher on the desktop.
Table 8.16, “Preferred Web Browser Preferences” lists the preferred web browser preferences that you can modify.

Table 8.16. Preferred Web Browser Preferences
Dialog Element

Description

Select a Web Browser

Select this option if you want to use a standard web browser. Use the drop-down
combination box to select your preferred web browser.

Custom Web Browser

Select this option if you want to use a custom web browser.

Command

Enter the command to execute to start the custom web browser. To enable the
browser to display a URL that you click on, include "%s" after the command.
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Dialog Element

Description

Start in Terminal

Select this option to run the command in a terminal window. Select this option for
a browser that does not create a window in which to run.

Email Client Preferences
Use the Mail Reader tabbed section to configure your preferred email client.
Table 8.17, “Preferred Email Client Preferences” lists the preferred email client preferences that you can modify.

Table 8.17. Preferred Email Client Preferences
Dialog Element

Description

Select a Mail Reader

Select this option if you want to use a standard email client. Use the drop-down
combination box to select your preferred email client.

Custom Mail Reader

Select this option if you want to use a custom email client.

Command

Enter the command to execute to start the custom email client.

Start in Terminal

Select this option to run the command in a terminal window. Select this option for
an email client that does not create a window in which to run.

Text Editor Preferences
Use the Text Editor tabbed section to configure your preferred text editor.
Table 8.18, “Preferred Text Editor Preferences” lists the preferred text editor preferences that you can modify.

Table 8.18. Preferred Text Editor Preferences
Dialog Element

Description

Select an Editor

Select this option if you want to use a standard text editor. Use the drop-down
combination box to specify your preferred text editor.

Custom Editor

Select this option if you want to use a custom text editor. A Custom Editor Properties dialog is displayed.
•

Name: Type the name of the custom text editor.

•

Command: Enter the command to start the custom text editor.

•

This application can open multiple files: Select this option if the default text
editor can open multiple files.

•

This application needs to be run in a shell: Select this option to run the command in a terminal window. Select this option for an editor that does not create
a window in which to run.
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Dialog Element

Remote Desktop Preferences

Description
After you specify a custom text editor, you can click on the Properties button to
display the Custom Editor Properties dialog. You can use the dialog to modify the
properties of the custom text editor.

Use this editor to open text files Select this option if you want the file manager to start the custom text editor to disin the file manager
play text files.

Terminal Preferences
Use the Terminal tabbed section to configure your preferred terminal.
Table 8.19, “Preferred Terminal Preferences” lists the preferred terminal preferences that you can modify.

Table 8.19. Preferred Terminal Preferences
Dialog Element

Description

Select a Terminal

Select this option if you want to use a standard terminal. Use the drop-down combination box to specify your preferred terminal.

Custom Terminal

Select this option if you want to use a custom terminal.

Command

Enter the command to execute to start the custom terminal.

Exec Flag

Enter the exec option to use with the command.

Remote Desktop Preferences
The Remote Desktop preference tool enables you to share a GNOME Desktop session between multiple users, and
to set session-sharing preferences.
Table 8.20, “Session Sharing Preferences” lists the session-sharing preferences that you can set. These preferences
have a direct impact on the security of your system.

Table 8.20. Session Sharing Preferences
Dialog Element

Description

Allow other users to view your Select this option to enable remote users to view your session. All keyboard,
desktop
pointer, and clipboard events from the remote user are ignored.
Allow other users to control your Select this option to enable other to access and control your session from a remote
desktop
location.
Users can view your desktop us- Click on the highlighted text to system address by email to a remote user.
ing this command:
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Dialog Element

Screen Resolution Preferences

Description

When a user tries to view or con- Select the following security considerations when a user tries to view or control
trol your desktop
your session:

Password

•

Ask you for confirmation: Select this option if you want remote users to ask
you for confirmation when they want to share your session. This option enables you to be aware of other users who connect to your session. You can
also decide what time is suitable for the remote user to connect to your session.

•

Require the user to enter this password: Select this option to authenticate the
remote user if authentication is used. This option provides an extra level of security.

Enter the password that the client who attempts to view or control your session
must enter.

Screen Resolution Preferences
Use the Screen Resolution preference tool to specify the resolution settings for your screen. Table 8.21, “Screen
Resolution Preferences” lists the screen resolution preferences that you can modify.

Table 8.21. Screen Resolution Preferences
Dialog Element

Description

Resolution

Select the resolution to use for the screen from the dropdown list.

Refresh rate

Select the screen refresh rate to use for the screen from
the drop-down list.

Make default for this computer only

Select this option to make the screen resolution settings
the default settings for the system that you are logged in
to only.

Screensaver Preferences
A screensaver displays moving images on your screen when your computer is not being used. Screensavers also
help prevent older monitors being damaged by the same image being displayed for long periods of time.
Use the Screensaver preference tool to set the type of screensaver, the time before the screensaver starts, and whether to require a password to return to the desktop.
You can modify the following settings:
Screensaver
Select the type of screensaver to display. The preview area to the right of the list shows the how the selected
screensaver will look on your screen.
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•

The Blank screen screensaver displays no image and only shows a black screen.

•

The Random screensaver selects a screensaver to display from the list at random.

Which screensavers are shown in the remainder of the list depends on your distributor or vendor.
Set session as idle after ... minutes
If GNOME receives no input from you for this length of time (such as moving the mouse or typing), the computer is set as idle. This may affect power management (the monitor may power down for example) or instant
messaging (chat applications may set your status as "away"). Use the slider to set the length of time in minutes.
Activate the screensaver when session is idle
Select this option to have the screensaver start after the set length of time. To stop the screensaver and return to
the desktop, move the mouse or press a key on the keyboard.
Lock screen when screensaver is active
When this option is selected, the screensaver will prompt you for your password when you try to return to the
desktop. For more on locking your screen, see the section called “Locking Your Screen”.

Sessions Preferences
The Sessions preference tool enables you to manage your sessions. You can set session preferences, and specify
which applications to start when you start a session. You can configure sessions to save the state of applications in
the GNOME Desktop, and to restore the state when you start another session. You can also use this preference tool
to manage multiple GNOME sessions.
You can customize the settings for sessions and startup applications in the following functional areas:
•

Session Options

•

Current Session

•

Startup Programs

Setting Session Preferences
Use the Session Options tabbed section to manage multiple sessions, and to set preferences for the current session.
Table 8.22, “Session Options” lists the session options that you can modify.

Table 8.22. Session Options
Dialog Element

Description

Show splash screen on login

Select this option to display a splash screen when you start a session.

Prompt on logout

Select this option to display a confirmation dialog when you end a session.

Automatically save changes to Select this option if you want the session manager to save the current state of your
session
session. The session manager saves the session-managed applications that are
open, and the settings associated with the session-managed applications. The next
time that you start a session, the applications start automatically, with the saved
settings.
If you do not select this option, when you end your session the Logout Confirmation dialog displays a Save current setup option.
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Dialog Element

Description

Sessions

Use this area of the dialog to manage multiple sessions in the GNOME Desktop,
as follows:
•

To create a new session, click on the Add button. The Add a new session dialog is displayed. Use this dialog to specify a name for your session.

•

To change the name of a session, select the session in the Sessions table. Click
on the Edit button. The Edit session name dialog is displayed. Type a new
name for your session.

•

To delete a session, select the session in the Sessions table. Click on the Delete
button.

When you log in on GDM, you choose a session. When you choose a session, you
can select which of the multiple sessions to use.

Setting Session Properties
Use the Current Session tabbed section to specify startup order values, and to choose restart styles for the sessionmanaged applications in your current session.
Table 8.23, “Session Properties” lists the session properties that you can configure.

Table 8.23. Session Properties
Dialog Element

Description

Order

The Order property specifies the order in which the session manager starts sessionmanaged startup applications. The session manager starts applications with lower
order values first. The default value is 50.
To specify the startup order of an application, select the application in the table.
Use the Order spin box to specify the startup order value.

Style

The Style property determines the restart style of an application. To select a restart
style for an application, select the application in the table, then choose one of the
following styles:
•

Normal
Starts automatically when you start a GNOME session.

•

Restart
Restarts automatically whenever you close or terminate the application.
Choose this style for an application if the application must run continuously
during your session.

•

Trash
Does not start when you start a GNOME session.

•

Settings
Starts automatically when you start a session. Applications with this style usu117
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Description
ally have a low startup order, and store your configuration settings for
GNOME and session-managed applications.

Remove

Click on the Remove button to delete the selected application from the list. The
application is removed from the session manager, and closed. If you save the session after doing this any deleted applications will not start the next time you start a
session.

Apply

Click on the Apply button to apply changes to the startup order and the restart
style.

Configuring Startup Applications
Use the Startup Programs tabbed section of the Sessions preference tool to specify non-session-managed startup applications. Startup applications are applications that start automatically when you start a session. You specify the
commands that run the non-session-managed applications in the Startup Programs tabbed section. The commands
execute automatically when you log in.
You can also start session-managed applications automatically. For more information, see the section called “Setting
Session Preferences”.
Table 8.24, “Startup Programs Preferences” lists the startup applications preferences that you can modify.

Table 8.24. Startup Programs Preferences
Dialog Element

Description

Additional startup programs

Use this table to manage non-session-managed startup applications as follows:
•

To add a startup application, click on the Add button. The Add Startup Program dialog is displayed. Enter the command to start the application in the
Startup Command field.
If you specify more than one startup application, use the Priority spin box to
specify the startup order of the each application. The startup order is the order
in which you want the startup applications to start.

•

To edit a startup application, select the startup application, then click on the
Edit button. The Edit Startup Program dialog is displayed. Use the dialog to
modify the command and the startup order for the startup application.

•

To delete a startup application, select the startup application, then click on the
Delete button.
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Sound Preferences
The Sound preference tool enables you to control when the GNOME sound server starts. You can also specify which
sounds to play when particular events occur.
You can customize the settings for the Sound preference tool in the following functional areas:
•

General

•

Sound Events

•

System Bell

General Sound Preferences
Use the General tabbed section of the Sound preference tool to specify when to launch the GNOME sound server.
You can also enable sound event functions.
Table 8.25, “General Sound Preferences” lists the general sound preferences that you can modify.

Table 8.25. General Sound Preferences
Dialog Element

Description

Enable sound server startup

Select this option to start the GNOME sound server when you start a GNOME
session. When the sound server is active, the GNOME Desktop can play sounds.

Sounds for events

Select this option to play sounds when particular events occur in the GNOME
Desktop. You can select this option only if the Enable sound server startup option
is selected.

Sound Event Preferences
Use the Sound Events tabbed section of the Sound preference tool to associate particular sounds with particular
events.
You must select the Enable sound server startup option, and the Sounds for events option before you
can access the Sound Events tabbed section.
Table 8.26, “Sound Event Preferences” lists the sound events preferences that you can modify.

Table 8.26. Sound Event Preferences
Dialog Element

Description

Sounds table

Use the Sounds table to associate particular sounds with particular events.
The Event column displays a hierarchical list of events that can occur. To expand
a category of events, click on the right arrow beside a category of events.
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Description
The File to play column lists the sound file that plays when the event occurs.

Play

Click on this button to play the sound file that is associated with the selected
event.

Sound file drop-down combina- To associate a sound with an event, select the event in the Sounds table. Enter the
tion box, Browse
name of the sound file that you want to associate with the selected event in the
drop-down combination box. Alternatively, click Browse to display a Select
sound file dialog. Use the dialog to specify the sound file that you want to associate with the selected event.
You can only associate sound files in .wav format with events.

System Bell Settings
Use the System Bell tabbed section to set your preferences for the system bell.
Some applications play a bell sound to indicate a keyboard input error. Use the preferences in the System Bell
tabbed section to configure the bell sound. Table 8.27, “System Bell Preferences” lists the system bell preferences
that you can modify.

Table 8.27. System Bell Preferences
Dialog Element

Description

Sound an audible bell

Select this option to enable the system bell.

Visual feedback

Select this option to enable visual feedback to indicate input errors.

Flash window titlebar

Select this option if you want window titlebars to flash to indicate an input error.

Flash entire screen

Select this option if you want the entire screen to flash to indicate an input error.

Theme Preferences
A theme is a group of coordinated settings that specifies the visual appearance of a part of the GNOME Desktop.
You can choose themes to change the appearance of the GNOME Desktop. Use the Theme preference tool to select
a theme. You can choose from a list of available themes. The list of available themes includes several themes for
users with accessibility requirements.
A theme contains settings that affect different parts of the GNOME Desktop, as follows:
Controls
The controls setting for a theme determines the visual appearance of windows, panels, and applets. The controls
setting also determines the visual appearance of the GNOME-compliant interface items that appear on windows, panels, and applets, such as menus, icons, and buttons. Some of the controls setting options that are available are designed for special accessibility needs. You can choose an option for the controls setting from the
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Controls tabbed section in the Theme Details.
Window frame
The window frame setting for a theme determines the appearance of the frames around windows only. You can
choose an option for the window frame setting from the Window Border tabbed section in the Theme Details.
Icon
The icon setting for a theme determines the appearance of the icons on panels and the desktop background. You
can choose an option for the icon setting from the Icons tabbed section in the Theme Details.

To Create a Custom Theme
The themes that are listed in the Theme preferences tool are different combinations of controls options, window
frame options, and icon options. You can create a custom theme that uses different combinations of controls options,
window frame options, and icon options.
To create a custom theme, perform the following steps:
1.

Start the Theme preference tool.

2.

Select a theme in the list of themes.

3.

Click on the Theme Details button. A Theme Details dialog is displayed.

4.

Select the controls option that you want to use in the custom theme from the list in the Controls tabbed section.
The list of available controls options includes several options for users with accessibility requirements.

5.

Click on the Window Border tab to display the Window Border tabbed section. Select the window frame option
that you want to use in the custom theme from the list of available options. The list of available window frame
options includes several options for users with accessibility requirements.

6.

Click on the Icons tab to display the Icons tabbed section. Select the icons option that you want to use in the
custom theme from the list of available options. The list of available icons options includes several options for
users with accessibility requirements.

7.

Click Close to close the Theme Details dialog.

8.

On the Theme preferences tool, click on the Save theme button. A Save theme to disk dialog is displayed.

9.

Type a name and a short description for the custom theme in the dialog, then click Save. The custom theme
now appears in your list of available themes.

To Install a New Theme
You can add a theme to the list of available themes. The new theme must be an archive file that is tarred and zipped.
That is, the new theme must be a .tar.gz file.
To install a new theme, perform the following steps:
1.

Start the Theme preference tool.

2.

Click on the Install Theme button. A Theme Installation dialog is displayed.

3.

Enter the location of the theme archive file in the drop-down combination box. Alternatively, to browse for the
file, click on the Browse button. When you have selected the file, click OK.

4.

Click on the Install button to install the new theme.

To Install a New Theme Option
You can install new controls options, window frame options, or icons options. You can find many controls options
on the Internet.
To install a new controls option, window frame option, or icons option, perform the following steps:
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1.

Start the Theme preference tool.

2.

Click on the Theme Details button. An Theme Details dialog is displayed.

3.

Click on the tab for the type of theme that you want to install. For example, to install an icons option, click on
the Icons tab.

4.

Click on the Install Theme button. A Theme Installation dialog is displayed.

5.

Enter the location of the option archive file in the drop-down combination box. Alternatively, to browse for the
file, click on the Browse button. When you have selected the file, click OK.

6.

Click on the Install button to install the new option.

To Delete a Theme Option
You can delete controls options, window frame options, or icons options.
To delete a controls option, window frame option, or icons option, perform the following steps:
1.

Start the Theme preference tool.

2.

Click on the Theme Details button. A Theme Details dialog is displayed.

3.

Click on the tab for the type of option that you want to delete.

4.

Click on the Go To Theme Folder button. A file manager window opens on the default option folder.

5.

Use the file manager window to delete the option.

Previewing Themes
As well as the Theme preference tool, you can also use the file manager to change themes. To change themes, perform the following steps:
1.

Use the file manager to access the themes:/// URI. The themes are displayed as icons.

2.

Double-click on a theme to change the theme.

Windows Preferences
Use the Windows preference tool to customize window behavior for the GNOME Desktop.
Table 8.28, “Windows Preferences” lists the windows preferences that you can modify.

Table 8.28. Windows Preferences
Dialog Element

Description

Select windows when the mouse Select this option to give focus to a window when you point to the window. The
moves over them
window retains focus until you point to another window.
Raise selected windows after an Select this option to raise windows a short time after the window receives focus.
interval
Interval before raising

Specify the interval to wait before raising a window that has received focus.

Double-click titlebar to perform Select the behavior that you want to occur when you double-click on a window tithis action
tlebar. Select one of the following options:
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Description
•

Maximize: Maximizes the window.

•

Roll up: Roll up the window.

To move a window, press- Select the key to press-and-hold when you drag a window to move the window.
and-hold this key then grab the
window
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applet

An applet is a small, interactive application that resides within a panel, for example the CD Player. Each applet has a simple user interface that you can operate with the mouse or keyboard.

desktop

The part of the GNOME Desktop where there are no interface graphical items,
such as panels and windows.

desktop background

The image or color that is applied to your desktop.

desktop object

An icon on your desktop that you can use to open your files, folders, and applications. You can use desktop objects to provide convenient access to files,
folders, and applications that you use frequently.

DNS name

A unique alphabetic identifier for a computer on a network.

drawer

A drawer is a sliding extension to a panel that you can open or close from a
drawer icon.

file extension

The final portion of a file's name, after the last period (.) in the name. For example, the file extension of the file picture.jpeg is jpeg.
The file extension can identify the type of a file. Nautilus file manager uses this
information when to determine what to do when you open a file. For more on
this, see the section called “Opening Files”.

format
GNOME-compliant
tion

To format media is to prepare the media for use with a particular file system.
When you format media, you overwrite any existing information on the media.
applica-

An application that uses the standard GNOME programming libraries is called a
GNOME-compliant application. For example, Nautilus file manager and gedit
text editor are GNOME-compliant applications.

IP address

A unique numeric identifier for a computer on a network.

keyboard shortcut

A keyboard shortcut is a key or combination of keys that provides an alternative
to standard ways of performing an action.

launcher

A launcher starts a particular application, executes a command, or opens a file.
A launcher can reside in a panel or in a menu.

menubar

A menubar is a bar at the top of an application window that contains the menus
for the application.

MIME type

A Multipurpose Internet Mail Extension (MIME) type identifies the format of a
file. The MIME type enables applications to read the file. For example, an email
application can use the image/png MIME type to detect that a Portable Networks Graphic (PNG) file is attached to an email.

mount

To mount is to make a file system available for access. When you mount a file
system, the file system is attached as a subdirectory to your file system.

pane

A pane is a subdivision of a window. For example, the Nautilus window contains a side pane and a view pane.

preference tool

A dedicated software tool that controls a particular part of the behavior of the
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shortcut keys

Shortcut keys are keystrokes that provide a quick way to perform an action.

stacking order

The stacking order is the order in which windows are stacked on top of each other on your screen.

statusbar

A statusbar is a bar at the bottom of a window that provides information about
the current state of what you are viewing in the window.

symbolic link

A special type of file that points to another file or folder. When you perform an
action on a symbolic link, the action is performed on the file or folder to which
the symbolic link points.

toolbar

A toolbar is a bar that contains buttons for the most commonly-used commands
in an application. Typically, a toolbar appears under a menubar.

Uniform Resource Identifier

A Uniform Resource Identifier (URI) is a string that identifies a particular location in a file system or on the Web. For example, the address of a web page is a
URI.

Uniform Resource Locator

A Uniform Resource Locator (URL) is the address of a particular location on the
Web.

view

A Nautilus component that enables you to display a folder in a particular way.
For example, Nautilus contains an icon view which enables you to display the
contents of a folder as icons. Nautilus also contains a list view which enables
you to display the contents of a folder as a list.

workspace

A workspace is a discrete area in the GNOME Desktop in which you can work.
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Index
A
accessibility
bounce keys, 106
configuring keyboard, 104
mouse keys, 106
repeat keys, 105
setting assistive technology preferences, 99
slow keys, 105
sticky keys, 105
toggle keys, 106
access keys, 7
AccessX (see preference tools, Keyboard Accessibility)
action buttons (see buttons)
applets
introduction, 29
Notification Area, 37
selecting, 27
applications
overview, 14
terminating, 32

B
backgrounds
adding colors, 75
adding patterns, 75
changing screen component, 74
customizing desktop background, 100
basic skills
keyboard skills, 5
mouse skills, 2
bottom edge panel
default contents, 24
introduction, 24
burning CDs (see writing CDs)
buttons
adding to panel, 32
Force Quit, 32
Lock, 32
Log Out, 33
Minimise Windows, 34
Run, 33
Screenshot, 34
Search, 34

C
CDs, writing, 77
create
hidden, 72

D
default applications (see preferred applications)
desktop

customizing background, 100
login photo, 104
Desktop Menu, 40
drawers
adding objects to, 35
adding to panel, 35
closing, 35
modifying properties, 36
opening, 35

E
email client, preferred application, 113
emblems
adding new, 74
adding to file, 74
adding to folder, 74
introduction, 73
events, associating sounds with, 119

F
file manager
adding actions, 57
bookmarks, 71
changing backgrounds, 74
changing permissions, 69
copying files and folders, 65
creating documents, 66
creating folders, 66
creating symbolic link, 68
customizing, 80
deleting files or folders, 67
drag-and-drop, 64
duplicating files and folders, 66
emblems (see emblems)
executing default actions for files, 56, 59
executing non-default actions for files, 56
FTP sites (see FTP sites)
History, 56
Home folder, 54
Home location (see Home location)
icons
caption preferences, 82
changing, 74
introduction, 73
icon view
arranging files in, 61
illustration, 47
introduction, 44
list view
arranging files in, 62
managing files and folders, 60
modifying actions, 57
modifying appearance of files and folders, 73
moving files and folders, 65
navigating, 46
navigating history list, 55
network places (see network places)
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notes
adding, 70
deleting, 70
opening files, 56
preferences
behavior, 81
icon captions, 82
introduction, 80
preference tool, 102
preview, 84
views, 80
renaming folders, 67
running scripts, 85
searching files, 57
selecting files and folders, 63
special URI locations, 79
Trash (see Trash)
Tree, using , 55
viewing properties, 68
views
introduction, 60
window components, showing and hiding, 53, 53
windows, 50
writing CDs, 77
zooming in and out, 62
fonts
applications, 102
desktop, 102
previewing, 103
rendering, 102
terminal, 102
window title, 102
Force Quit button, 32
FTP sites
accessing, 78

configuring accessibility options, 104
configuring general preferences, 107
configuring sound preferences, 120
keyboard shortcuts
configuring, 108

L
language, logging in in different, 19
launchers
adding to panel, 30
modifying properties, 30
Lock button, 20, 32
locking panel objects, 29
locking screen, 20, 32
logging in
to session, 19
to session in different language, 19
logging out, 21
Log Out button, 33

M

G
GNOME Desktop components, introducing, 9
GNOME Desktop preference tools (see preference tools)
(see preference tools)
GTK+ themes (see themes, controls options)

H
hidden
files, 72
Home location
displaying, 49, 54

I
icon themes (see themes, icons options)
Internet
configuring connection, 111

K
keyboard
basic skills, 5

Main Menu
adding to panel, 37
introduction, 37
Menu Bar
adding to panel, 37
introduction, 39
menus
adding, 41
adding launchers to, 41
adding to panel, 34
Applications menu, 39
copying launchers to, 41
customizing, 40
deleting menu items, 42
editing menu items, 42
editing properties, 42
in applications, customizing appearance, 109
introduction, 39
Main Menu (see Main Menu)
Menu Bar (see Menu Bar)
Metacity themes (see themes, window frame options)
Minimise Windows button, 34
mouse
action conventions, 2
actions, 3
action terminology, 2
basic skills, 2
button conventions, 2
configuring, 110
pointers, 4

N
network places
accessing, 79
network proxy
setting preferences, 111
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NFS servers (see Unix network)
notes
adding to files and folders, 70
deleting, 70
Notification Area applet, 37

P
panel object popup menu, illustration, 28
panel objects
adding, 27
applets (see applets)
drawers (see drawers)
Force Quit button, 32
interacting with, 26
launchers (see launchers)
Lock button, 32
locking, 29
Log Out button, 33
menus, 34
Minimise Windows button, 34
modifying properties, 27
moving, 28
Notification Area applet, 37
removing, 29
Run button, 33
Screenshot button, 34
Search button, 34
panels
adding new, 26
bottom edge panel (see bottom edge panel)
changing background, 25
deleting, 26
hiding, 26
introduction, 23
managing, 24
modifying properties, 24
moving, 24
panel objects (see panel objects)
top edge panel (see top edge panel)
permissions
and emblems, 73
changing file and folder, 69
displaying as characters, 83, 84
displaying in octal notation, 83, 83
introduction, 69
Places menu, 39
pointers (see mouse pointers)
preferences, file manager (see file manager preferences)
preference tools
Assistive Technology, 99
Background, 100
CD Database, 100
File Management, 102
Font, 102
Keyboard, 107
Keyboard Accessibility, 104
Keyboard Shortcuts, 108
Login Photo, 104

Menus & Toolbars, 109
Mouse, 110
Network Proxy, 111
Preferred Applications, 112
Screen Resolution, 115
screensaver, 115
Sessions, 20, 116
Sound, 119
Theme, 120
Windows, 122
preferred applications
email client, 113
terminal, 114
text editor, 113
web browser, 112
proxy
setting preferences, 111

Q
quit, 21

R
removable media
displaying media contents, 76
displaying media properties, 76
ejecting, 76
formatting floppy diskette, 76
introduction, 75
mounting, 75
Run Application dialog, using, 88
Run button, 33

S
Samba servers (see Windows network)
Screenshot button, 34
screenshots, taking, 88
scripts, running from file manager, 85
Search button, 34
sessions
browsing applications, 21
different language, logging in, 19
ending, 21
locking screen, 20
logging in, 19
logging out, 21
login behavior, 20
logout behavior, 20
managing, 20
preferences, 116
saving settings, 21
setting options, 116
setting properties, 117
starting, 19
using startup applications, 20
setting session sharing preferences, 114
shortcut keys
application, 7
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configuring, 108
global, 5
window, 6
shutdown, 21
sound
associating events with sounds, 119
configuring system bell preferences, 120
setting preferences, 119
sound server, 119
special URI locations
accessing, 79
and launchers, 29
special URIs
launchers, 32
start session, 19
startup applications
customizing, 116
non-session-managed, 20, 118
session-managed, 20, 116, 117
startup programs (see startup applications)
symbolic link
to file or folder, creating, 68
symbolic links
and emblems, 73
system bell
configuring preferences, 120

viewer components, 60

W
web browser, preferred application, 112
window manager
customizing, 122
windows
overview, 10
setting frame theme options, 120
window selector
top edge panel, 36
workspaces
overview, 13
specifying number of, 14
switching between, 14
writing CDs, 77

Y
Yelp, 89

T
terminal, preferred application, 114
terminating applications, 32
text editor, preferred application, 113
themes
controls options
introduction, 120
icons options
introduction, 121
setting controls options, 120
setting icons options, 120
setting window frame options, 120
window frame options
introduction, 121
toolbars, customizing appearance, 109
top edge panel
introduction, 23
window list icon, 23
window selector icon, 36
Trash
displaying, 72
emptying, 72
introduction, 71
moving files or folders to, 67
Tree, using, 55

U
URI, special (see special URI locations)
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